summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm84
1 files changed, 79 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 31ba037af0..18ea6148c8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 nee <nee-git@hidamari.blue>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -116,6 +117,8 @@
#:use-module (gnu packages messaging)
#:use-module (gnu packages upnp)
#:use-module (gnu packages wxwidgets)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages flex)
#:use-module (guix build-system gnu)
#:use-module (guix build-system haskell)
#:use-module (guix build-system python)
@@ -2849,6 +2852,7 @@ safety of the Chromium vessel.")
,(string-append "PREFIX=" %output)
"GNOME_PREFIX=$(PREFIX)"
"COMPLETIONDIR=$(PREFIX)/etc/bash_completion.d")
+ #:parallel-build? #f ;fails on some systems
#:tests? #f ;No tests
#:phases (modify-phases %standard-phases
(delete 'configure) ;no configure phase
@@ -3169,7 +3173,7 @@ throwing people around in pseudo-randomly generated buildings.")
(define-public hyperrogue
(package
(name "hyperrogue")
- (version "9.4c")
+ (version "9.4g")
;; When updating this package, be sure to update the "hyperrogue-data"
;; origin in native-inputs.
(source (origin
@@ -3180,7 +3184,7 @@ throwing people around in pseudo-randomly generated buildings.")
"-src.tgz"))
(sha256
(base32
- "1ri5fllnhqjm3dlnl1xbb9mlv79iigc940vbvcnk0v5k6p58pavq"))))
+ "09j9gnx701x28zfkrv3rjqlr56p89hyxk78gkpmmdfjgcq076pc2"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -3235,14 +3239,14 @@ throwing people around in pseudo-randomly generated buildings.")
(string-append
"hyperrogue"
(string-join (string-split ,version #\.) "")
- "-win/sounds/credits.txt") "-d" sounds))
+ "/sounds/credits.txt") "-d" sounds))
;; Extract sounds and music into sounds directory.
(zero?
(system* "unzip" "-j" data
(string-append
"hyperrogue"
(string-join (string-split ,version #\.) "")
- "-win/*.ogg") "-d" sounds)))))))))
+ "/*.ogg") "-d" sounds)))))))))
(native-inputs
`(("hyperrogue-data"
,(origin
@@ -3254,7 +3258,7 @@ throwing people around in pseudo-randomly generated buildings.")
"-win.zip"))
(sha256
(base32
- "1cyyrsnrixygg3zyz97hpsm6jzwbhydiwk3kl0lm7qjnw2nzkhhh"))))
+ "1r57db4hm7fjcd27p8b6cdsnq2cgkym2kp9lrw7ha2asdf8w6gkb"))))
("unzip" ,unzip)))
(inputs
`(("font-dejavu" ,font-dejavu)
@@ -3807,3 +3811,73 @@ utter witty remarks about their surroundings, the various inhabitants of their
underwater realm quarrel among themselves or comment on the efforts of your
fish. The whole game is accompanied by quiet, comforting music.")
(license license:gpl2+)))
+
+(define-public crawl
+ (package
+ (name "crawl")
+ (version "0.19.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (list
+ ;; Older releases get moved into a versioned directory
+ (string-append "http://crawl.develz.org/release/"
+ (version-major+minor version) "/stone_soup-"
+ version "-nodeps.tar.xz")
+ ;; Only the latest release is in this directory
+ (string-append "http://crawl.develz.org/release/stone_soup-"
+ version "-nodeps.tar.xz")))
+ (sha256
+ (base32
+ "00yl2lb2shglxlxzpyk99zvglfx4amjybqwnzdcasvbiggb4cj18"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("lua51" ,lua-5.1)
+ ("ncurses" ,ncurses)
+ ("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ '(#:make-flags
+ (let* ((sqlite (assoc-ref %build-inputs "sqlite"))
+ (out (assoc-ref %outputs "out")))
+ (list (string-append "SQLITE_INCLUDE_DIR=" sqlite "/include")
+ (string-append "prefix=" out)
+ "SAVEDIR=~/.crawl"
+ ;; TODO: build graphical client
+ "TILES="
+ ;; don't build any bundled dependencies
+ "BUILD_LUA="
+ "BUILD_SQLITE="
+ "BUILD_ZLIB="
+ "-Csource"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ ;; Test cases require the source to be rebuild with the -DDEBUG define.
+ ;; Do 'check before 'build to avoid a 3rd build on make install.
+ (add-before 'build 'check
+ (lambda* (#:key inputs outputs make-flags #:allow-other-keys)
+ (setenv "HOME" (getcwd))
+ ;; Fake a terminal for the test cases.
+ (setenv "TERM" "xterm-256color")
+ (zero? (apply system* "make" "debug" "test"
+ (format #f "-j~d" (parallel-job-count))
+ make-flags)))))))
+ (synopsis "Roguelike dungeon crawler game")
+ (description "Dungeon Crawl Stone Soup is a roguelike adventure through
+dungeons filled with dangerous monsters in a quest to find the mystifyingly
+fabulous Orb of Zot.")
+ (home-page "https://crawl.develz.org")
+ (license (list license:gpl2+
+ license:bsd-2
+ license:bsd-3
+ license:cc0
+ license:expat
+ license:zlib
+ license:asl2.0))))