summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm75
1 files changed, 73 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d86e151a85..8f495f7b32 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -108,7 +108,7 @@ representation of the playing board.")
(define-public gnubik
(package
(name "gnubik")
- (version "2.4.1")
+ (version "2.4.2")
(source
(origin
(method url-fetch)
@@ -116,7 +116,7 @@ representation of the playing board.")
version ".tar.gz"))
(sha256
(base32
- "0mfpwz341i1qpzi2qgslpc5i7d4fv7i01kv392m11pczqdc7i7m5"))))
+ "0mhpfnxzbns0wfrsjv5vafqr34770rbvkmdzxk0x0aq67hb3zyl5"))))
(build-system gnu-build-system)
(inputs `(("gtk+" ,gtk+-2)
("mesa" ,mesa)
@@ -748,6 +748,43 @@ some of the restrictions in the venerable Z-machine format. This is the
reference interpreter, using Glk API.")
(license (license:fsf-free "file://README"))))
+(define-public fizmo
+ (package
+ (name "fizmo")
+ (version "0.7.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://christoph-ender.de/fizmo/source/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1w7cgyjrhgkadjrazijzhq7zh0pl5bfc6wl7mdpgh020y4kp46d7"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (let ((libjpeg (assoc-ref %build-inputs "libjpeg"))
+ (ncurses (assoc-ref %build-inputs "ncurses")))
+ (list (string-append "jpeg_CFLAGS=-I" libjpeg "/include")
+ (string-append "jpeg_LIBS=-ljpeg")
+ (string-append "ncursesw_CFLAGS=-I" ncurses "/include")
+ (string-append "ncursesw_LIBS=-lncursesw")))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libsndfile" ,libsndfile)
+ ("libxml2" ,libxml2)
+ ("ncurses" ,ncurses)
+ ("sdl" ,sdl)))
+ (home-page "https://christoph-ender.de/fizmo/")
+ (synopsis "Z-machine interpreter")
+ (description
+ "Fizmo is a console-based Z-machine interpreter. It is used to play
+interactive ficiton, also known as textadventures, which were implemented
+either by Infocom or created using the Inform compiler.")
+ (license license:bsd-3)))
+
(define-public retroarch
(package
(name "retroarch")
@@ -879,3 +916,37 @@ bones.
This game is based on the GPL version of the famous game TuxRacer.")
(home-page "http://sourceforge.net/projects/extremetuxracer/")
(license license:gpl2+)))
+
+(define-public gnujump
+ (package
+ (name "gnujump")
+ (version "1.0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gnujump/gnujump-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "05syy9mzbyqcfnm0hrswlmhwlwx54f0l6zhcaq8c1c0f8dgzxhqk"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'configure 'link-libm
+ (lambda _ (setenv "LIBS" "-lm"))))))
+ (inputs
+ `(("glu" ,glu)
+ ("mesa", mesa)
+ ("sdl" ,sdl)
+ ("sdl-image" ,sdl-image)
+ ("sdl-mixer" ,sdl-mixer)))
+ (home-page "http://gnujump.es.gnu.org/")
+ (synopsis
+ "Game of jumping to the next floor, trying not to fall")
+ (description
+ "GNUjump is a simple, yet addictive game in which you must jump from
+platform to platform to avoid falling, while the platforms drop at faster rates
+the higher you go. The game features multiplayer, unlimited FPS, smooth floor
+falling, themeable graphics and sounds, and replays.")
+ (license license:gpl3+)))