summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7b8d2f1bae..2ef93d6247 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1283,14 +1283,16 @@ fight Morgoth, the Lord of Darkness.")
(version "0.7.6")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/Pingus/pingus/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Pingus/pingus.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0r9v6as5vi7skvvy7b0fcaimhdlzmik64pyy68plgljhsghqkkf4"))
- (patches (search-patches "pingus-sdl-libs-config.patch"))))
+ "0wp06kcmknsnxz7bjnsndb8x062z7r23fb3yrnbfnj68qhz18y74"))
+ (patches (search-patches "pingus-boost-headers.patch"
+ "pingus-sdl-libs-config.patch"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("scons-python2" ,scons-python2)))