summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 26170f1cad..d41d3e1f66 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2213,7 +2213,24 @@ also available.")
(modify-phases %standard-phases
(add-before
'configure 'link-libm
- (lambda _ (setenv "LIBS" "-lm"))))))
+ (lambda _ (setenv "LIBS" "-lm")))
+ (add-after 'install 'create-desktop-entry
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (apps (string-append out "/share/applications")))
+ (mkdir-p apps)
+ (with-output-to-file
+ (string-append apps "/gnujump.desktop")
+ (lambda _
+ (format #t
+ "[Desktop Entry]~@
+ Name=GNUjump~@
+ Comment=Jump up the tower to survive~@
+ Exec=~a/bin/gnujump~@
+ Terminal=false~@
+ Type=Application~@
+ Categories=Game;ArcadeGame~%"
+ out)))))))))
(inputs
`(("glu" ,glu)
("mesa" ,mesa)