summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm35
1 files changed, 14 insertions, 21 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 30fa0463f4..4e7fb2e428 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3263,26 +3263,19 @@ tactics.")
(define-public starfighter
(package
(name "starfighter")
- (version "2.0.0.2")
- ;; As recommended by the upstream maintainer, use the git source code
- ;; instead of the released source tarball until missing files in the tarball
- ;; are added. The 'url-fetch' method may be appropriate again after the
- ;; next update. See https://github.com/pr-starfighter/starfighter/issues/1
- ;; for more details.
+ (version "2.0.0.3")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pr-starfighter/starfighter")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/pr-starfighter/starfighter/releases"
+ "/download/v" version "/starfighter-"
+ (version-major+minor version) "-src.tar.gz"))
(sha256
(base32
- "0p81ywgm2dxjbpmbsgx4f2d83sy6lv3hinrr1vzprkf9viidqnd2"))))
+ "13vi5kh9ahws4f52421cbyw0jn7pmbnld358lqfmr6flql7ilj3b"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("pango" ,pango)
("sdl2" ,sdl2)
@@ -6768,7 +6761,7 @@ fight each other on an arena-like map.")
(define-public flare-engine
(package
(name "flare-engine")
- (version "1.10")
+ (version "1.11")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6777,7 +6770,7 @@ fight each other on an arena-like map.")
(file-name (git-file-name name version))
(sha256
(base32
- "19l83145ya1wk666acr91b6917a63ak7l77d10i5im8xfhv29ml4"))))
+ "1mqr1s72p5bdh4kq2a8hg72dk8lwnddicjnd2cdp1sbfa9lmjym8"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no test
@@ -6796,7 +6789,7 @@ action RPGs.")
(define-public flare-game
(package
(name "flare-game")
- (version "1.10")
+ (version "1.11")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6805,7 +6798,7 @@ action RPGs.")
(file-name (git-file-name name version))
(sha256
(base32
- "0dx4f1j1n3p4q3h0r0fb89f0llvhg9lia0s247pacff3r88ljihk"))))
+ "0bd5g7sd89a9176ilr408hdqzdfv4j7wj0idd685c1n6s01c3h6p"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no test
@@ -7245,7 +7238,7 @@ and bring the war to your enemy.")
(define-public harmonist
(package
(name "harmonist")
- (version "0.1")
+ (version "0.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7254,7 +7247,7 @@ and bring the war to your enemy.")
(file-name (git-file-name name version))
(sha256
(base32
- "006vkhb84v78ssfwppc221n4za0y02ypg7ihrihin4vj4gllmzf7"))))
+ "0hqy9kqwgirwkq1v3vj1hp9m93hjvdj4nxcfbjfvvwk2bbzri3s2"))))
(build-system go-build-system)
(arguments
'(#:import-path "git.tuxfamily.org/harmonist/harmonist"))