aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index ee8dea23b5..13006f3509 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1998,7 +1998,11 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
#t))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DODE_WITH_LIBCCD_SYSTEM=ON")
+ ;; Tests fail on all systems but x86_64.
+ `(#:tests? ,(string=? "x86_64-linux"
+ (or (%current-target-system)
+ (%current-system)))
+ #:configure-flags '("-DODE_WITH_LIBCCD_SYSTEM=ON")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'unbundle-libccd