summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm78
1 files changed, 52 insertions, 26 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 13006f3509..ceec993d04 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2019, 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Jethro Cao <jethrocao@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -77,6 +78,7 @@
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages music)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
@@ -723,7 +725,7 @@ package is the Nuklear bindings for LÖVE created by Kevin Harrison.")
multimedia programming. It handles common, low-level tasks such as creating
windows, accepting user input, loading data, drawing images, playing sounds,
etc.")
- (home-page "http://liballeg.org")
+ (home-page "https://liballeg.org")
(license license:giftware)))
(define-public allegro
@@ -764,7 +766,7 @@ etc.")
multimedia programming. It handles common, low-level tasks such as creating
windows, accepting user input, loading data, drawing images, playing sounds,
etc.")
- (home-page "http://liballeg.org")
+ (home-page "https://liballeg.org")
(license license:bsd-3)))
(define-public allegro-5.0
@@ -1503,7 +1505,7 @@ games.")
(define-public godot
(package
(name "godot")
- (version "3.0.6")
+ (version "3.1.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1512,25 +1514,43 @@ games.")
(file-name (git-file-name name version))
(sha256
(base32
- "0g64h0x8dlv6aa9ggfcidk2mknkfl5li7z1phcav8aqp9srj8avf"))
- (modules '((guix build utils)))
+ "12305wj2i4067jc50l8r0wmb7zjcna24fli8vb8kiaild0jrlip6"))
+ (modules '((guix build utils)
+ (ice-9 ftw)
+ (srfi srfi-1)))
(snippet
'(begin
- ;; Drop libraries that we take from Guix. Note that some
- ;; of these may be modified; see "thirdparty/README.md".
+ ;; Keep only those bundled files we have not (yet) replaced
+ ;; with Guix versions. Note that some of these may be
+ ;; modified; see "thirdparty/README.md".
(with-directory-excursion "thirdparty"
- (for-each delete-file-recursively
- '("freetype"
- "libogg"
- "libpng"
- "libtheora"
- "libvorbis"
- "libvpx"
- "libwebp"
- "openssl"
- "opus"
- "zlib"))
- #t)))))
+ (let* ((preserved-files
+ '("README.md"
+ "b2d_convexdecomp"
+ "certs"
+ "cvtt"
+ "enet"
+ "etc2comp"
+ "fonts"
+ "glad"
+ "jpeg-compressor"
+ "libsimplewebm"
+ "libwebsockets"
+ "miniupnpc"
+ "minizip"
+ "misc"
+ "nanosvg"
+ "pvrtccompressor"
+ "recastnavigation"
+ "squish"
+ "thekla_atlas"
+ "tinyexr"
+ "xatlas")))
+ (for-each delete-file-recursively
+ (lset-difference string=?
+ (scandir ".")
+ (cons* "." ".." preserved-files)))))
+ #t))))
(build-system scons-build-system)
(arguments
`(#:scons ,scons-python2
@@ -1541,6 +1561,7 @@ games.")
'())
;; Avoid using many of the bundled libs.
;; Note: These options can be found in the SConstruct file.
+ "builtin_bullet=no"
"builtin_freetype=no"
"builtin_glew=no"
"builtin_libmpdec=no"
@@ -1550,9 +1571,11 @@ games.")
"builtin_libvorbis=no"
"builtin_libvpx=no"
"builtin_libwebp=no"
- "builtin_openssl=no"
+ "builtin_mbedtls=no"
"builtin_opus=no"
- "builtin_zlib=no")
+ "builtin_pcre2=no"
+ "builtin_zlib=no"
+ "builtin_zstd=no")
#:tests? #f ; There are no tests
#:phases
(modify-phases %standard-phases
@@ -1599,6 +1622,7 @@ games.")
#t))))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("alsa-lib" ,alsa-lib)
+ ("bullet" ,bullet)
("freetype" ,freetype)
("glew" ,glew)
("glu" ,glu)
@@ -1611,10 +1635,12 @@ games.")
("libxi" ,libxi)
("libxinerama" ,libxinerama)
("libxrandr" ,libxrandr)
+ ("mbedtls" ,mbedtls-apache)
("mesa" ,mesa)
- ("openssl" ,openssl)
("opusfile" ,opusfile)
- ("pulseaudio" ,pulseaudio)))
+ ("pcre2" ,pcre2)
+ ("pulseaudio" ,pulseaudio)
+ ("zstd" ,zstd "lib")))
(home-page "https://godotengine.org/")
(synopsis "Advanced 2D and 3D game engine")
(description
@@ -1999,9 +2025,9 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
(build-system cmake-build-system)
(arguments
;; Tests fail on all systems but x86_64.
- `(#:tests? ,(string=? "x86_64-linux"
- (or (%current-target-system)
- (%current-system)))
+ `(#:tests? ,(string-prefix? "x86_64-"
+ (or (%current-target-system)
+ (%current-system)))
#:configure-flags '("-DODE_WITH_LIBCCD_SYSTEM=ON")
#:phases
(modify-phases %standard-phases