summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm34
1 files changed, 30 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 63ccd20470..05a68b717a 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -153,15 +153,15 @@ is used in some video games and movies.")
(define-public deutex
(package
(name "deutex")
- (version "5.1.2")
+ (version "5.2.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/Doom-Utils/" name
+ (uri (string-append "https://github.com/Doom-Utils/deutex"
"/releases/download/v" version "/"
- name "-" version ".tar.xz"))
+ "deutex-" version ".tar.xz"))
(sha256
(base32
- "1rj3w4xa0n4jixy4j7p6gbclylbgxvhdnji7xnkydrqii9rxnbp4"))))
+ "1d536d3i78k4ch8mjg7lqnamnyfpp2x5x7mzx5smqi9ad8lb6hqz"))))
(build-system gnu-build-system)
(native-inputs `(("asciidoc" ,asciidoc)))
(home-page "https://github.com/Doom-Utils/deutex")
@@ -1511,3 +1511,29 @@ added. The permanent goal is to create the open source Quake 3 distribution
upon which people base their games, ports to new platforms, and other
projects.")
(license license:gpl2))))
+
+(define-public openvr
+ (package
+ (name "openvr")
+ (version "1.4.18")
+ (home-page "https://github.com/ValveSoftware/openvr/")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0m92634j6g0f2xybbzklm79cnq20vidbk1jc62pnz12aabwixvyh"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; No tests.
+ '(#:tests? #f
+ #:configure-flags (list "-DBUILD_SHARED=1")))
+ (synopsis "Virtual reality software development kit")
+ (description "OpenVR is an API and runtime that allows access to VR
+hardware from multiple vendors without requiring that applications have
+specific knowledge of the hardware they are targeting.")
+ (license license:bsd-3)))