summaryrefslogtreecommitdiff
path: root/gnu/packages/fribidi.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fribidi.scm')
-rw-r--r--gnu/packages/fribidi.scm54
1 files changed, 53 insertions, 1 deletions
diff --git a/gnu/packages/fribidi.scm b/gnu/packages/fribidi.scm
index 61aa6fd726..345529b73a 100644
--- a/gnu/packages/fribidi.scm
+++ b/gnu/packages/fribidi.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
-;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -54,3 +54,55 @@ or right-to-left ordering as necessary.")
(source
(origin (inherit (package-source fribidi))
(patches (search-patches "fribidi-CVE-2019-18397.patch"))))))
+
+(define-public bidiv
+ (package
+ (name "bidiv")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://debian/pool/main/b/bidiv/bidiv_"
+ version ".orig.tar.gz"))
+ (sha256
+ (base32
+ "05p5m2ihxbmc1qsgs8rjlww08fy9859fhl7xf196p8g5qygqd7cv"))
+ (patches (search-patches "bidiv-update-fribidi.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (add-after 'unpack 'misc-fixes
+ (lambda _
+ (substitute* "bidiv.c"
+ (("FriBidiCharType") "FriBidiParType")
+ (("&c") "(char *)&c"))
+ #t))
+ ;; We don't want to use the handwritten makefile
+ (replace 'build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((fribidi (assoc-ref inputs "fribidi")))
+ (invoke "gcc" "-o" "bidiv" "bidiv.c"
+ ;; pkg-config --cflags fribidi
+ (string-append "-I" fribidi "/include/fribidi")
+ ;; pkg-config --libs fribidi
+ (string-append "-L" fribidi "/lib") "-lfribidi"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (man (string-append out "/share/man/man1")))
+ (install-file "bidiv" bin)
+ (install-file "bidiv.1" man))
+ #t)))
+ #:tests? #f)) ; no tests
+ (inputs
+ `(("fribidi" ,fribidi)))
+ (home-page "https://tracker.debian.org/pkg/bidiv")
+ (synopsis "BiDi viewer - command-line tool displaying logical Hebrew/Arabic")
+ (description "bidiv is a simple utility for converting logical-Hebrew input
+to visual-Hebrew output. This is useful for reading Hebrew mail messages,
+viewing Hebrew texts, etc. It was written for Hebrew but Arabic (or other BiDi
+languages) should work equally well.")
+ (license gpl2+)))