summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm27
1 files changed, 11 insertions, 16 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index e917be7505..63adb4d076 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -259,6 +259,12 @@ the freedesktop.org XDG Base Directory specification.")
#:make-flags '("PKTTYAGENT=/run/current-system/profile/bin/pkttyagent")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-locale-header
+ (lambda _
+ ;; Fix compilation with glibc >= 2.26, which removed xlocale.h.
+ ;; This can be removed for elogind 234.
+ (substitute* "src/basic/parse-util.c"
+ (("xlocale\\.h") "locale.h"))))
(add-before 'configure 'autogen
(lambda _
(and (zero? (system* "intltoolize" "--force" "--automake"))
@@ -416,28 +422,17 @@ Python.")
(define-public wayland
(package
(name "wayland")
- (version "1.13.0")
+ (version "1.14.0")
(source (origin
(method url-fetch)
(uri (string-append "https://wayland.freedesktop.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "0lgywr1m0d79vr4s8aimj8a307nss29hhy68gjpqj7m667055c39"))))
+ "1f3sla6h0bw15fz8pjc67jhwj7pwmfdc7qlj42j5k9v116ycm07d"))))
(build-system gnu-build-system)
(arguments
- `(#:parallel-tests? #f
- #:phases
- (modify-phases %standard-phases
- ;; Remove record shapes to workaround graphviz 2.40.1 problems.
- ;; http://www.graphviz.org/content/i-havent-been-able-render-these-files-graphviz-226
- ;; This will likely be fixed upstream in the next release.
- ;; https://lists.freedesktop.org/archives/wayland-devel/2017-June/034218.html
- (add-before 'build 'fix-graphviz
- (lambda _
- (substitute* "doc/doxygen/dot/x-architecture.gv"
- (("Mrecord") "none"))
- #t)))))
+ `(#:parallel-tests? #f))
(native-inputs
`(("doxygen" ,doxygen)
("graphviz" ,graphviz)
@@ -463,7 +458,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(define-public wayland-protocols
(package
(name "wayland-protocols")
- (version "1.9")
+ (version "1.12")
(source (origin
(method url-fetch)
(uri (string-append
@@ -471,7 +466,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
"wayland-protocols-" version ".tar.xz"))
(sha256
(base32
- "0xag2yci0l13brmq2k12vdv0wlnb2j0rxk2cnp170fya63g74sv6"))))
+ "1cn8ny4zr9xlcdh8qi1qnkmvia8cp4ixnsbhd9sp9571w6lyh69v"))))
(build-system gnu-build-system)
(inputs
`(("wayland" ,wayland)))