summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 67f1e1a2c0..2032dce66a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -618,6 +619,65 @@ received by the Telepathy framework. It features pluggable backends to log
different sorts of messages in different formats.")
(license license:lgpl2.1+)))
+(define-public telepathy-idle
+ (package
+ (name "telepathy-idle")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://telepathy.freedesktop.org/releases/"
+ name "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1argdzbif1vdmwp5vqbgkadq9ancjmgdm2ncp0qfckni715ss4rh"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("xsltproc" ,libxslt)
+ ("python" ,python-2)
+ ("python-dbus" ,python2-dbus)))
+ (propagated-inputs
+ `(("telepathy-glib" ,telepathy-glib)))
+ (home-page "http://telepathy.freedesktop.org/")
+ (synopsis "Telepathy IRC connection manager")
+ (description
+ "Idle is an IRC connection manager for the Telepathy framework. This
+package enables usage of IRC channels and private messages in Telepathy instant
+messaging clients such as Empathy, GNOME Shell or KDE Telepathy.")
+ (license (list license:lgpl2.1 license:lgpl2.1+))))
+
+(define-public telepathy-mission-control
+ (package
+ (name "telepathy-mission-control")
+ (version "5.16.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://telepathy.freedesktop.org/releases/"
+ name "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0zcbx69k0d3p2pjh3g7sa3q2zkd5xchxkqsmlfn3fwxaz0pmsmvi"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("dconf" ,dconf)
+ ("gtk-doc" ,gtk-doc)
+ ("libgnome-keyring" ,libgnome-keyring)
+ ("python" ,python-2)
+ ("xsltproc" ,libxslt)))
+ (propagated-inputs
+ `(("telepathy-glib" ,telepathy-glib)))
+ (home-page "https://telepathy.freedesktop.org/wiki/Components/Mission_Control/")
+ (synopsis "Telepathy real-time communication framework management daemon")
+ (description
+ "Telepathy Mission Control 5 is an account manager and channel dispatcher
+for the Telepathy framework, allowing user interfaces and other clients to
+share connections to real-time communication services without conflicting.")
+ (license license:lgpl2.1)))
+
(define-public colord-gtk
(package
(name "colord-gtk")