summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 0262d0a1ed..67f1e1a2c0 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -295,6 +295,28 @@ application, or a wayland client itself. The clients can be traditional
applications, X servers (rootless or fullscreen) or other display servers.")
(license license:x11)))
+(define-public wayland-protocols
+ (package
+ (name "wayland-protocols")
+ (version "1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://wayland.freedesktop.org/releases/"
+ "wayland-protocols-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0wpm7mz7ww6nn3vrgz7a9iyk7mk6za73wnq0n54lzl8yq8irljh1"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("wayland" ,wayland)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Wayland protocols")
+ (description "This package contains XML definitions of the Wayland protocols.")
+ (home-page "https://wayland.freedesktop.org")
+ (license license:expat)))
+
(define-public exempi
(package
(name "exempi")