summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index de6293aacd..d2306a9423 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -618,3 +618,44 @@ to provide base functionality so that you can focus on your application’s
behavior, not object observing or maintaining cached data. Defcon
implements UFO3 as described by the UFO font format.")
(license license:expat)))
+
+(define-public nototools
+ (package
+ (name "nototools")
+ (version "20170925")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/googlei18n/nototools/"
+ "archive/v2017-09-25-tooling-for-phase3-"
+ "update.tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pvacw18cm9l4sb66pqyjc7hc74xhhfxc7kd5ald8lixf4wzg0s8"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (propagated-inputs
+ `(("python2-booleanoperations" ,python2-booleanoperations)
+ ("python2-defcon" ,python2-defcon)
+ ("python2-fonttools" ,python2-fonttools)
+ ("python2-pillow" ,python2-pillow)
+ ("python2-pyclipper" ,python2-pyclipper)
+ ("python2-ufolib" ,python2-ufolib)))
+ (home-page "https://github.com/googlei18n/nototools")
+ (synopsis "Noto fonts support tools and scripts")
+ (description
+ "Nototools is a Python package containing Python scripts used to
+maintain the Noto Fonts project.")
+ (license (list license:asl2.0
+ ;; Sample texts are attributed to UN and OHCHR.
+ ;; The permissions on the UDHR are pretty lax:
+ ;; http://www.ohchr.org/EN/UDHR/Pages/Introduction.aspx
+ ;; "If UDHR translations or materials are reproduced, users
+ ;; should make reference to this website as a source by
+ ;; providing a link."
+ license:public-domain
+ (license:non-copyleft
+ "file://sample_texts/attributions.txt"
+ "See sample_texts/attributions.txt in the distribution.")))))