summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm101
1 files changed, 64 insertions, 37 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 71d7a19e1d..ea2f509d89 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +46,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gperf)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages fribidi)
#:use-module (gnu packages gtk)
#:use-module (gnu packages xml)
#:use-module (gnu packages sqlite)
@@ -255,44 +257,35 @@ work with most software requiring Type 1 fonts.")
(license license:bsd-3)))
(define-public woff2
- (let ((commit "4e698b8c6c5e070d53c340db9ddf160e21070ede")
- (revision "1"))
- (package
- (name "woff2")
- (version (string-append "20160306-" revision "."
- (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/woff2.git")
- (commit commit)))
- (file-name (string-append name "-" version ".tar.xz"))
- (sha256
- (base32
- "0wka0yhf0cjmd4rv2jckxpyv6lb5ckj4nj0k1ajq5hrjy7f30lcp"))
- (patches (list (search-patch "woff2-libbrotli.patch")))))
- (build-system gnu-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("brotli" ,brotli)))
- (arguments
- `(#:tests? #f ;no tests
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (install-file "woff2_compress" bin)
- (install-file "woff2_decompress" bin)
- #t))))))
- (synopsis "Compress TrueType fonts to WOFF2")
- (description
- "This package provides utilities for compressing/decompressing TrueType
+ (package
+ (name "woff2")
+ (version "1.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/woff2.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version ".git"))
+ (sha256
+ (base32
+ "13l4g536h0pr84ww4wxs2za439s0xp1va55g6l478rfbb1spp44y"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("google-brotli" ,google-brotli)))
+ (arguments
+ ;; package has no tests
+ `(#:tests? #f
+ ;; we can’t have both, shared libraries and binaries, so turn off the
+ ;; former
+ #:configure-flags (list "-DBUILD_SHARED_LIBS=OFF")))
+ (synopsis "Compress TrueType fonts to WOFF2")
+ (description
+ "This package provides utilities for compressing/decompressing TrueType
fonts to/from the WOFF2 format.")
- (license license:asl2.0)
- (home-page "https://github.com/google/woff2"))))
+ (license license:asl2.0)
+ (home-page "https://github.com/google/woff2")))
(define-public fontconfig
(package
@@ -857,3 +850,37 @@ work well with other GTK+ desktop environments.")
samples that show coverage of the font and are similar in appearance to
Unicode Charts. It was developed for use with DejaVu Fonts project.")
(license license:gpl3+)))
+
+(define-public libraqm
+ (package
+ (name "libraqm")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/HOST-Oman/libraqm/"
+ "releases/download/v" version "/"
+ "raqm-" version ".tar.gz"))
+ (sha256
+ (base32 "0hgry3fj2y3qaq2fnmdgd93ixkk3ns5jds4vglkiv2jfvpn7b1g2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list "--disable-static")))
+ (native-inputs
+ `(("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)))
+ (inputs
+ `(("freetype" ,freetype)
+ ("fribidi" ,fribidi)
+ ("harfbuzz" ,harfbuzz)))
+ (home-page "https://github.com/HOST-Oman/libraqm")
+ (synopsis "Library for complex text layout")
+ (description
+ "Raqm is a small library that encapsulates the logic for complex text
+layout and provides a convenient API.
+
+It currently provides bidirectional text support (using FriBiDi),
+shaping (using HarfBuzz), and proper script itemization. As a result, Raqm
+can support most writing systems covered by Unicode.")
+ (license license:expat)))