summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 19d5171956..d34b4b42f9 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -53,13 +53,13 @@
(define-public freetype
(package
(name "freetype")
- (version "2.8")
+ (version "2.8.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/freetype/freetype-"
version ".tar.bz2"))
(sha256 (base32
- "02xlj611alpvl3h33hvfw1jyxc1vp9mzwcckkiglkhn3hknh7im3"))))
+ "0y3xrimgp0k39gwq1vdi7b7wjy0z9fhwmzafisxqfardw015yhz5"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -230,20 +230,21 @@ fonts to/from the WOFF2 format.")
(define-public fontconfig
(package
(name "fontconfig")
- (version "2.12.3")
+ (version "2.12.6")
(source (origin
(method url-fetch)
(uri (string-append
"https://www.freedesktop.org/software/fontconfig/release/fontconfig-"
version ".tar.bz2"))
+ (patches (search-patches "fontconfig-remove-debug-printf.patch"))
(sha256 (base32
- "1ggq6jmz3mlzk4xjs615aqw9h3hq33chjn82bhli26kk09kby95x"))))
+ "05zh65zni11kgnhg726gjbrd55swspdvhqbcnj5a5xh8gn03036g"))))
(build-system gnu-build-system)
(propagated-inputs `(("expat" ,expat)
("freetype" ,freetype)))
(inputs `(("gs-fonts" ,gs-fonts)))
(native-inputs
- `(("gperf" ,gperf) ; Try dropping this for > 2.12.3.
+ `(("gperf" ,gperf)
("pkg-config" ,pkg-config)))
(arguments
`(#:configure-flags
@@ -262,13 +263,6 @@ fonts to/from the WOFF2 format.")
"PYTHON=false")
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'regenerate-fcobjshash
- ;; XXX The pre-generated gperf files are broken.
- ;; See <https://bugs.freedesktop.org/show_bug.cgi?id=101280>.
- (lambda _
- (delete-file "src/fcobjshash.h")
- (delete-file "src/fcobjshash.gperf")
- #t))
(replace 'install
(lambda _
;; Don't try to create /var/cache/fontconfig.
@@ -412,7 +406,8 @@ and returns a sequence of positioned glyphids from the font.")
"/potrace-" version ".tar.gz"))
(sha256
(base32
- "17ajildjp14shsy339xarh1lw1p0k60la08ahl638a73mh23kcx9"))))
+ "17ajildjp14shsy339xarh1lw1p0k60la08ahl638a73mh23kcx9"))
+ (patches (search-patches "potrace-tests.patch"))))
(build-system gnu-build-system)
(native-inputs `(("ghostscript" ,ghostscript))) ;for tests
(inputs `(("zlib" ,zlib)))
@@ -442,6 +437,8 @@ resolution.")
(sha256
(base32 "0239zvfan56w7vrppriwy77fzb10ag9llaz15nsraps2a2x6di3v"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(propagated-inputs
`(("freetype" ,freetype)))
(home-page "http://www.nongnu.org/m17n/")
@@ -556,7 +553,11 @@ definitions.")
"libxml2" "zlib" "libspiro" "freetype"
"pango" "cairo" "fontconfig")))
;; Checks for potrace program at runtime
- `("PATH" ":" prefix (,potrace)))))))))
+ `("PATH" ":" prefix (,potrace)))))))
+
+ ;; Skip test 40 "FontForge .sfd file open check" to work around
+ ;; <https://github.com/fontforge/fontforge/issues/3246>.
+ #:make-flags '("TESTSUITEFLAGS=-k '!\\.sfd'")))
(synopsis "Outline font editor")
(description
"FontForge allows you to create and modify postscript, truetype and
@@ -582,7 +583,7 @@ generate bitmaps.")
`(("python2-fonttools" ,python2-fonttools)))
(native-inputs
`(("unzip" ,unzip)
- ("python2-pytest-3.0" ,python2-pytest-3.0)
+ ("python2-pytest" ,python2-pytest)
("python2-pytest-runner" ,python2-pytest-runner)))
(home-page "https://github.com/unified-font-object/ufoLib")
(synopsis "Low-level UFO reader and writer")
@@ -607,7 +608,7 @@ files. UFO is a file format that stores fonts source files.")
`(#:python ,python-2))
(native-inputs
`(("unzip" ,unzip)
- ("python2-pytest-3.0" ,python2-pytest-3.0)
+ ("python2-pytest" ,python2-pytest)
("python2-pytest-runner" ,python2-pytest-runner)))
(propagated-inputs
`(("python2-fonttools" ,python2-fonttools)