summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm19
1 files changed, 8 insertions, 11 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 1982d0bf4b..cddd067517 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -57,13 +57,13 @@
(define-public freetype
(package
(name "freetype")
- (version "2.9.1")
+ (version "2.10.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/freetype/freetype-"
version ".tar.bz2"))
(sha256 (base32
- "0kg8w6qyiizlyzh4a8lpzslipcbv96hcg3rqqpnxba8ffbm8g3fv"))))
+ "01mybx78n3n9dhzylbrdy42wxdwfn8rp514qdkzjy6b5ij965k7w"))))
(build-system gnu-build-system)
(arguments
;; The use of "freetype-config" is deprecated, but other packages still
@@ -428,7 +428,7 @@ applications should be.")
(define-public graphite2
(package
(name "graphite2")
- (version "1.3.12")
+ (version "1.3.13")
(source
(origin
(method url-fetch)
@@ -436,7 +436,7 @@ applications should be.")
"download/" version "/" name "-" version ".tgz"))
(sha256
(base32
- "1l1940d8fz67jm6a0x8cjb5p2dv48cvz3wcskwa83hamd70k15fd"))))
+ "01jzhwnj1c3d68dmw15jdxly0hwkmd8ja4kw755rbkykn1ly2qyx"))))
(build-system cmake-build-system)
(native-inputs
`(("python" ,python-2) ; because of "import imap" in tests
@@ -555,14 +555,14 @@ definitions.")
(define-public fontforge
(package
(name "fontforge")
- (version "20190317")
+ (version "20190413")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/fontforge/fontforge/releases/download/"
version "/fontforge-" version ".tar.gz"))
- (sha256 (base32
- "1ddqbpc32cgbccdnv0lfw0qhj59hcqzb7616ph5lkvm91pnas4dp"))))
+ (sha256
+ (base32 "05v640mnk4fy4jzmxb6c4n4qm800x7hy4sl5gcdgzmm3md2s0qk7"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -586,10 +586,7 @@ definitions.")
("libxml2" ,libxml2)
("pango" ,pango)
("potrace" ,potrace)
- ;; FIXME: We use Python 2 here because there is a bug in Python
- ;; 3.7 that is triggered when Py_Main is called after Py_Init, as
- ;; is done by fontforge. This will be fixed in Python 3.7.1.
- ("python" ,python-2)
+ ("python" ,python)
("zlib" ,zlib)))
(arguments
'(#:phases