summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm84
1 files changed, 75 insertions, 9 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index dbc0c4f9d6..34db6ff3ec 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Brendan Tildesley <mail@brendan.scot>
-;;; Copyright © 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Mohammed Sadiq <sadiq@sadiqpk.org>
;;; Copyright © 2018 Charlie Ritter <chewzerita@posteo.net>
;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
@@ -32,6 +32,7 @@
;;; Copyright © 2020 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -64,9 +65,11 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages xorg))
(define-public font-ibm-plex
@@ -230,9 +233,9 @@ The Lato 2.010 family supports more than 100 Latin-based languages, over
50 Cyrillic-based languages as well as Greek and IPA phonetics.")
(license license:silofl1.1)))
-(define-public font-gnu-freefont-ttf
+(define-public font-gnu-freefont
(package
- (name "font-gnu-freefont-ttf")
+ (name "font-gnu-freefont")
(version "20120503")
(source (origin
(method url-fetch)
@@ -249,18 +252,41 @@ The Lato 2.010 family supports more than 100 Latin-based languages, over
(lambda _
(let ((doc-dir (string-append %output "/share/doc/"
,name "-" ,version))
- (font-dir (string-append %output
- "/share/fonts/truetype")))
+ (ttf-font-dir (string-append %output
+ "/share/fonts/ttf"))
+ (otf-font-dir (string-append %output
+ "/share/fonts/otf"))
+ (woff-font-dir (string-append %output
+ "/share/fonts/woff")))
(mkdir-p doc-dir)
(substitute* "Makefile"
(("\\$\\(TMPDIR\\)") doc-dir)
- (("sfd/\\*.ttf") ""))
- (system* "make" "ttftar")
- (mkdir-p font-dir)
+ (("sfd/\\*.ttf") "")
+ (("sfd/\\*.otf") "")
+ (("sfd/\\*.woff") ""))
+ ;; XXX The FreeFont Makefile tries to use the current
+ ;; time and date as names for generated files, and fails
+ ;; silently. But the fonts are still installed, so we
+ ;; leave the issue alone for now.
+ ;; See <https://bugs.gnu.org/40783>
+ (system* "make" "ttftar" "otftar" "wofftar")
+ (mkdir-p ttf-font-dir)
+ (mkdir-p otf-font-dir)
+ (mkdir-p woff-font-dir)
(for-each (lambda (file)
- (install-file file font-dir))
+ (install-file file ttf-font-dir))
(filter
(lambda (file) (string-suffix? "ttf" file))
+ (find-files "." "")))
+ (for-each (lambda (file)
+ (install-file file otf-font-dir))
+ (filter
+ (lambda (file) (string-suffix? "otf" file))
+ (find-files "." "")))
+ (for-each (lambda (file)
+ (install-file file woff-font-dir))
+ (filter
+ (lambda (file) (string-suffix? "woff" file))
(find-files "." "")))))))
#:test-target "tests"))
;; replace python 3 with python 2
@@ -1670,3 +1696,43 @@ always uses Farsi digits, and does not include Latin glyphs from Roboto.
(license:x11-style ; ...the Bitstream Vera typeface
"file://LICENSE" "Bitstream Vera License")
license:asl2.0)))) ; Latin glyphs from Roboto
+
+(define-public font-meera-inimai
+ (package
+ (name "font-meera-inimai")
+ (version "2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/smc/meera-inimai")
+ (commit "0f39cdd7dbf1b6d1bed7df85834d33789dce20a7")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1x5mhrpx24imh0r4l83mkaiszxgwi1q4ppyyvq63h3ddwk20cwdg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("fontforge" ,fontforge)
+ ("harfbuzz" ,harfbuzz "bin")
+ ("python" ,python-minimal)
+ ("python-fonttools" ,python-fonttools)
+ ("python-google-brotli" ,python-google-brotli)))
+ (arguments
+ `(#:make-flags (list "PY=python3"
+ (string-append "DESTDIR=" %output)
+ "fontpath=/share/fonts/truetype")
+ #:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://gitlab.com/smc/meera-inimai")
+ (synopsis "Meera Inimai Tamil font")
+ (description "Meera Inimai is a Unicode font for the Tamil Script. Meera
+Inimai is a san-serif typeface. It is best used as a screen font for body
+text. It is also useful for body text of printed pamphlets or single page
+designs. Meera Inimai can be thought of as similar to Helvetica and its
+variation Arial. Tamil characters are inherently vertically-elliptical. The
+orthography of Roman glyphs of Meera Inimai are also based on this
+characteristic so that they sit smoothly with the Tamil glyphs.")
+ (license license:silofl1.1)))