summaryrefslogtreecommitdiff
path: root/gnu/packages/flashing-tools.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/flashing-tools.scm')
-rw-r--r--gnu/packages/flashing-tools.scm106
1 files changed, 105 insertions, 1 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 9683c6b4a3..5309510d40 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -31,10 +31,12 @@
#:use-module (gnu packages)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (gnu packages bison)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
#:use-module (gnu packages elf)
+ #:use-module (gnu packages pciutils)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages libusb)
#:use-module (gnu packages libftdi)
@@ -138,7 +140,7 @@ brick your device.")
(native-inputs
`(("bison" ,bison)
("flex" ,flex)))
- (home-page "http://www.nongnu.org/avrdude/")
+ (home-page "https://www.nongnu.org/avrdude/")
(synopsis "AVR downloader and uploader")
(description
"AVRDUDE is a utility to download/upload/manipulate the ROM and
@@ -330,3 +332,105 @@ USB and interacts with low-level software running on the device, known as Loke.
Loke and Heimdall communicate via the custom Samsung-developed protocol typically
referred to as the \"Odin 3 protocol\".")
(license license:expat)))
+
+(define-public ifdtool
+ (package
+ (name "ifdtool")
+ (version "4.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://review.coreboot.org/p/coreboot")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nw555i0fm5kljha9h47bk70ykbwv8ddfk6qhz6kfqb79vzhy4h2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ "INSTALL=install"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "util/ifdtool")
+ #t))
+ (delete 'configure)
+ (delete 'check))))
+ (home-page "https://github.com/corna/me_cleaner/")
+ (synopsis "Intel Firmware Descriptor dumper")
+ (description "This package provides @command{ifdtool}, a program to
+dump Intel Firmware Descriptor data of an image file.")
+ (license license:gpl2)))
+
+(define-public intelmetool
+ (package
+ (name "intelmetool")
+ (version "4.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://review.coreboot.org/p/coreboot")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nw555i0fm5kljha9h47bk70ykbwv8ddfk6qhz6kfqb79vzhy4h2"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("pciutils" ,pciutils)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ "INSTALL=install"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "util/intelmetool")
+ #t))
+ (delete 'configure)
+ (delete 'check))))
+ (home-page "https://github.com/zamaudio/intelmetool")
+ (synopsis "Intel Management Engine tools")
+ (description "This package provides tools for working with Intel
+Management Engine (ME). You need to @code{sudo rmmod mei_me} and
+@code{sudo rmmod mei} before using this tool. Also pass
+@code{iomem=relaxed} to the Linux kernel command line.")
+ (license license:gpl2)))
+
+(define-public me-cleaner
+ (package
+ (name "me-cleaner")
+ (version "1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/corna/me_cleaner/"
+ "archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pgwdqy0jly80nhxmlmyibs343497yjzs6dwfbkcw0l1gjm8i5hw"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'create-setup.py
+ (lambda _
+ (call-with-output-file "setup.py"
+ (lambda (port)
+ (format port "\
+from setuptools import setup
+setup(name='me_cleaner', version='~a', scripts=['me_cleaner.py'])
+" ,version)))
+ #t)))))
+ (home-page "https://github.com/corna/me_cleaner")
+ (synopsis "Intel ME cleaner")
+ (description "This package provides tools for disabling Intel
+ME as far as possible (it only edits ME firmware image files).")
+ (license license:gpl3+)))