summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index fc26b77279..377cb3a405 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1111,3 +1111,31 @@ information.")
(description "This allows a Trezor hardware wallet to communicate to the
Trezor wallet.")
(license license:lgpl3+)))
+
+(define-public bitcoin-abc
+ (package
+ (inherit bitcoin-core)
+ (name "bitcoin-abc")
+ (version "0.19.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.bitcoinabc.org/"
+ version "/linux/src/bitcoin-abc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ndvkxv5m8346bdhfqzgdiz1k9wyjycj05jp7daf9pml3cw79sz5"))))
+ (home-page "https://www.bitcoinabc.org/")
+ (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
+ (description
+ "Bitcoin Cash brings sound money to the world, fulfilling the original
+promise of Bitcoin as Peer-to-Peer Electronic Cash. Merchants and users are
+empowered with low fees and reliable confirmations is a digital currency that
+enables instant payments to anyone anywhere in the world. It uses
+peer-to-peer technology to operate without central authority: managing
+transactions and issuing money are carried out collectively by the network.
+As a fork it implemented changes lowering the time between blocks and now
+offers confimations after less than 5 seconds and have significantly lower
+fees that BTC. Bitcoin ABC is the reference implementation of the Bitcoin
+Cash protocol. This package provides the Bitcoin Cash command line client and
+a client based on Qt. This is a fork of Bitcoin Core.")))