aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm92
1 files changed, 46 insertions, 46 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 250b1db144..ce67694cfe 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -6,10 +6,10 @@
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
-;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
@@ -139,17 +139,17 @@ line client and a client based on Qt.")
(package
(name "ledger")
(version "3.1.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/ledger/ledger/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "12jlv3gsjhrja25q9hrwh73cdacd2l3c2yyn8qnijav9mdhnbw4h"))
- (patches (search-patches "ledger-revert-boost-python-fix.patch"
- "ledger-fix-uninitialized.patch"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ledger/ledger.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j4p7djkmdmd858hylrsc3inamh9z0vkfl98s9wiqfmrzw51pmxp"))
+ (patches (search-patches "ledger-revert-boost-python-fix.patch"
+ "ledger-fix-uninitialized.patch"))))
(build-system cmake-build-system)
(arguments
`(#:modules ((guix build cmake-build-system)
@@ -252,16 +252,16 @@ in ability, and easy to use.")
(version "0.9.13")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/stesie/geierlein"
- "/archive/V" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stesie/geierlein.git")
+ (commit (string-append "V" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "11jfa7mxvvf0ldhx0hsvjbx3xwvzvn2wrfjpms8c7qmrnqhwh4wp"))))
+ (base32 "00zpwr3lk2vdmd60fgdwdk0xxs52wvnm19ln2m75yfphydvkglic"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; would require npm, python and a lot more
+ `(#:tests? #f ; would require npm, python and a lot more
#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configure script
@@ -590,13 +590,13 @@ Monero GUI client.")
(version "0.9.4")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/romanz/trezor-agent/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/romanz/trezor-agent.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0h8jb147vpjk7mqbl4za0xdh7lblhx07n9dfk80kn2plwnvrry1x"))))
+ (base32 "15aaqk79d9y9nbsfznf2iscz12z5ispcj8kr8v5bc0sqqj2brs12"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -604,7 +604,7 @@ Monero GUI client.")
(delete 'check)
(add-after 'install 'check
(lambda* (#:key outputs inputs #:allow-other-keys)
- ;; Make installed package available for running the tests
+ ;; Make installed package available for running the tests.
(add-installed-pythonpath inputs outputs)
(invoke "py.test"))))))
(propagated-inputs
@@ -855,7 +855,7 @@ Luhn and family of ISO/IEC 7064 check digit algorithms. ")
(define-public python-duniterpy
(package
(name "python-duniterpy")
- (version "0.51.0")
+ (version "0.52.0")
(source
(origin
(method git-fetch)
@@ -866,7 +866,7 @@ Luhn and family of ISO/IEC 7064 check digit algorithms. ")
(file-name (git-file-name name version))
(sha256
(base32
- "074mh2kh3s00ib0h99050ss3j4c51v57py6dzm7crida6l0iydbv"))))
+ "07liba2d21hb8m3n6yccfamq9yq0ryywh18vs9g2sgywfsnv82lh"))))
(build-system python-build-system)
(arguments
;; Tests fail with "AttributeError: module 'attr' has no attribute 's'".
@@ -884,16 +884,17 @@ Luhn and family of ISO/IEC 7064 check digit algorithms. ")
(copy-recursively "docs/_build/html" doc))
#t)))))
(native-inputs
- `(("python-sphinx" ,python-sphinx)
- ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
+ `(("sphinx" ,python-sphinx)
+ ("sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
(propagated-inputs
- `(("python-aiohttp" ,python-aiohttp)
- ("python-attr" ,python-attr)
- ("python-base58" ,python-base58)
- ("python-jsonschema" ,python-jsonschema)
- ("python-libnacl" ,python-libnacl)
- ("python-pylibscrypt" ,python-pylibscrypt)
- ("python-pypeg2" ,python-pypeg2)))
+ `(("aiohttp" ,python-aiohttp)
+ ("attr" ,python-attr)
+ ("base58" ,python-base58)
+ ("jsonschema" ,python-jsonschema)
+ ("libnacl" ,python-libnacl)
+ ("pyaes" ,python-pyaes)
+ ("pylibscrypt" ,python-pylibscrypt)
+ ("pypeg2" ,python-pypeg2)))
(home-page "https://git.duniter.org/clients/python/duniterpy")
(synopsis "Python implementation of Duniter API")
(description "@code{duniterpy} is an implementation of
@@ -912,7 +913,7 @@ main features are:
(define-public silkaj
(package
(name "silkaj")
- (version "0.6.1")
+ (version "0.6.5")
(source
(origin
(method git-fetch)
@@ -922,17 +923,16 @@ main features are:
(file-name (git-file-name name version))
(sha256
(base32
- "0a99gbgdd7m9wisqhqpfyaim0rlv9gkp8gmrppkagqf6j0683igh"))))
+ "1fy509vsmz7rs9m3vah0ky0jvq9mxmfga6b18rkrkl2lbjk872q2"))))
(build-system python-build-system)
(arguments
`(#:tests? #f)) ;no test
(inputs
- `(("python-commandlines" ,python-commandlines)
- ("python-ipaddress" ,python-ipaddress)
- ("python-pyaes" ,python-pyaes)
- ("python-pynacl" ,python-pynacl)
- ("python-scrypt" ,python-scrypt)
- ("python-tabulate" ,python-tabulate)))
+ `(("click" ,python-click)
+ ("duniterpy" ,python-duniterpy)
+ ("ipaddress" ,python-ipaddress)
+ ("pynacl" ,python-pynacl)
+ ("tabulate" ,python-tabulate)))
(home-page "https://silkaj.duniter.org/")
(synopsis "Command line client for Duniter network")
(description "@code{Silkaj} is a command line client for the