summaryrefslogtreecommitdiff
path: root/gnu/packages/file.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/file.scm')
-rw-r--r--gnu/packages/file.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index 3bc8e1dcfe..63aa3fac49 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -27,16 +27,15 @@
(define-public file
(package
- (replacement file/fixed)
(name "file")
- (version "5.30")
+ (version "5.32")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.astron.com/pub/file/file-"
version ".tar.gz"))
(sha256
(base32
- "057jpcyy8ws7q4s4sm8r1rxb8xycdbng2z4y9i98f094wlr28k39"))))
+ "0l1bfa0icng9vdwya00ff48fhvjazi5610ylbhl35qi13d6xqfc6"))))
(build-system gnu-build-system)
;; When cross-compiling, this package depends upon a native install of
@@ -50,11 +49,4 @@ you in words what kind of data a file contains. It does not rely on filename
extensions to tell you the type of a file, but looks at the actual contents
of the file.")
(license bsd-2)
- (home-page "http://www.darwinsys.com/file/")))
-
-(define file/fixed
- (package
- (inherit file)
- (source (origin
- (inherit (package-source file))
- (patches (search-patches "file-CVE-2017-1000249.patch"))))))
+ (home-page "https://www.darwinsys.com/file/")))