summaryrefslogtreecommitdiff
path: root/gnu/packages/fcitx.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fcitx.scm')
-rw-r--r--gnu/packages/fcitx.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/fcitx.scm b/gnu/packages/fcitx.scm
index b05d9b7146..e699d7d59d 100644
--- a/gnu/packages/fcitx.scm
+++ b/gnu/packages/fcitx.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,20 +30,21 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages iso-codes)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
(define-public fcitx
(package
(name "fcitx")
- (version "4.2.9.6")
+ (version "4.2.9.7")
(source (origin
(method url-fetch)
(uri (string-append "http://download.fcitx-im.org/fcitx/"
- name "-" version "_dict.tar.xz"))
+ "fcitx-" version "_dict.tar.xz"))
(sha256
(base32
- "0hyrh3v82a32ylnlvzrp6cmq56x4p1a42q5xc6njmmj2msxm34x5"))))
+ "13vg7yzfq0vj2r8zdf9ly3n243nwwggkhd5qv3z6yqdyj0m3ncyg"))))
(build-system cmake-build-system)
(outputs '("out" "gtk2" "gtk3"))
(arguments
@@ -81,6 +82,7 @@
("gtk3" ,gtk+)
("icu4c" ,icu4c)
("iso-codes" ,iso-codes)
+ ("json-c" ,json-c)
("libxkbfile" ,libxkbfile)
("libxml2" ,libxml2)
("xkeyboard-config" ,xkeyboard-config)))
@@ -99,7 +101,7 @@ built-in.")
(source (origin
(method url-fetch)
(uri (string-append "https://download.fcitx-im.org/fcitx-configtool/"
- name "-" version ".tar.xz"))
+ "fcitx-configtool-" version ".tar.xz"))
(sha256
(base32
"1yyi9jhkwn49lx9a47k1zbvwgazv4y4z72gnqgzdpgdzfrlrgi5w"))))