summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 512dd9b099..b42e631b98 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -59,7 +59,7 @@
(define-public efl
(package
(name "efl")
- (version "1.19.1")
+ (version "1.20.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -67,7 +67,7 @@
version ".tar.xz"))
(sha256
(base32
- "0fndwraca9rg0bz3al4isdprvyw56szr88qiyvglb4j8ygsylscc"))))
+ "1d1wmmwgc8pf6lk9g6lflpdxvg85wxxq650d6m30zgr85cb6d27q"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -286,14 +286,17 @@ embedded systems.")
(define-public python-efl
(package
(name "python-efl")
- (version "1.19.0")
+ (version "1.20.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "python-efl" version))
+ (uri (list
+ (pypi-uri "python-efl" version)
+ (string-append "http://download.enlightenment.org/rel/bindings/"
+ "python/python-efl-" version ".tar.gz")))
(sha256
(base32
- "0l0f9bv1134qh5376p5asycncidrhp8hdb6qwd8ybr1a61q9zq67"))))
+ "1680pgpf501nhbc9arm0nfj6rpcw17aryh0pgmmmszxlgpifpdzy"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -312,11 +315,7 @@ embedded systems.")
(lambda _
;; Some tests require write access to HOME.
(setenv "HOME" "/tmp")
- #t)))
- ;; FIXME: Some tests require a running D-Bus server or a network
- ;; connection and should be disabled. Other test failures looks
- ;; legitimate. Disabled for now, needs work!
- #:tests? #f))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("python-cython" ,python-cython)))