summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 449584f57e..aee60bd697 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -329,7 +329,9 @@ featuring various improvements and bug fixes.")))
"0x37vfp6k0d2z3gnig0hbicvi0jp8v267xjnn3z8jdllpiaa6p3k"))
(snippet
;; Remove a non-free file.
- '(delete-file "doc/psfig.sty"))
+ '(begin
+ (delete-file "doc/psfig.sty")
+ #t))
(patches (search-patches "fastcap-mulSetup.patch"
"fastcap-mulGlobal.patch"))))
(build-system gnu-build-system)
@@ -592,7 +594,8 @@ as well as pick-place files.")
;; Use #include <catch.hpp>.
(substitute* (find-files "." "\\.[ch]pp$")
(("catch/catch\\.hpp")
- "catch.hpp"))))))
+ "catch.hpp"))
+ #t))))
(build-system cmake-build-system)
(arguments
`(;; Have the RUNPATH of libao.so point to $libdir, where libefsw.so
@@ -1152,7 +1155,8 @@ bindings for Python, Java, OCaml and more.")
(substitute* "libr/parse/p/Makefile"
(("LDFLAGS\\+=") "LDFLAGS+=-Wl,-rpath=$(LIBDIR) "))
(substitute* "libr/bin/p/Makefile"
- (("LDFLAGS\\+=") "LDFLAGS+=-Wl,-rpath=$(LIBDIR) "))))))
+ (("LDFLAGS\\+=") "LDFLAGS+=-Wl,-rpath=$(LIBDIR) "))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f; tests require git and network access
@@ -1257,7 +1261,8 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
(("src/ciderlib/input/Makefile") "")
(("src/ciderlib/support/Makefile") "")
(("src/ciderlib/oned/Makefile") "")
- (("src/ciderlib/twod/Makefile") ""))))))
+ (("src/ciderlib/twod/Makefile") ""))
+ #t))))
(build-system gnu-build-system)
(arguments
`(;; No tests for libngspice exist.