summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm68
1 files changed, 63 insertions, 5 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 308501f882..75045f25b3 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018 Theodoros Foradis <theodoros@foradis.org>
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -690,8 +691,8 @@ language.")
(method url-fetch)
(file-name (string-append name "-" version ".tar.xz"))
(uri (string-append
- "https://launchpad.net/kicad/5.0/" version "/+download/" name
- "-" version ".tar.xz"))
+ "https://launchpad.net/kicad/" (version-major+minor version)
+ "/" version "/+download/" name "-" version ".tar.xz"))
(sha256
(base32 "17nqjszyvd25wi6550j981whlnb1wxzmlanljdjihiki53j84x9p"))))
(build-system cmake-build-system)
@@ -710,7 +711,9 @@ language.")
;; headers in the wxwidgets store item, but in wxPython.
(string-append "-DCMAKE_CXX_FLAGS=-I"
(assoc-ref %build-inputs "wxpython")
- "/include/wx-3.0")
+ "/include/wx-"
+ ,(version-major+minor
+ (package-version python2-wxpython)))
"-DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE"
"-DKICAD_SPICE=TRUE"
;; TODO: Enable this when CA certs are working with curl.
@@ -732,7 +735,10 @@ language.")
(file (string-append out "/bin/kicad"))
(path (string-append
out
- "/lib/python2.7/site-packages:"
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages:"
(getenv "PYTHONPATH"))))
(wrap-program file
`("PYTHONPATH" ":" prefix (,path))
@@ -1853,3 +1859,55 @@ The S letter indicates SPICE. The purpose of the Qucs-S subproject is to use
free SPICE circuit simulation kernels with the Qucs GUI. It provides the
simulator backends @code{Qucsator}, @code{ngspice} and @code{Xyce}.")
(license license:gpl2+)))
+
+(define-public librepcb
+ (package
+ (name "librepcb")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.librepcb.org/releases/0.1.0/librepcb-"
+ version "-source.zip"))
+ (sha256
+ (base32
+ "0affvwwgs1j2wx6bb3zfa2jbfxpckklr8cka2nkswca0p82wd3dv"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("qttools" ,qttools) ; for lrelease
+ ("unzip" ,unzip)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (mkdir-p "build")
+ (chdir "build")
+ (let ((lrelease (string-append (assoc-ref inputs "qttools")
+ "/bin/lrelease"))
+ (out (assoc-ref outputs "out")))
+ (invoke "qmake"
+ (string-append "QMAKE_LRELEASE=" lrelease)
+ (string-append "PREFIX=" out)
+ "../librepcb.pro")))))))
+ (home-page "https://librepcb.org/")
+ (synopsis "Electronic Design Automation tool")
+ (description "LibrePCB is @dfn{Electronic Design Automation} (EDA)
+software to develop printed circuit boards. It features human readable file
+formats and complete project management with library, schematic and board
+editors.")
+ (license (list license:gpl3+
+ license:boost1.0 ; libs/clipper,
+ ; libs/optional/tests/catch.hpp,
+ ; libs/sexpresso/tests/catch.hpp
+ license:expat ; libs/delaunay-triangulation,
+ ; libs/parseagle, libs/type_safe
+ license:asl2.0 ; libs/fontobene, libs/googletest,
+ ; libs/parseagle
+ license:isc ; libs/hoedown
+ license:cc0 ; libs/optional, libs/sexpresso
+ license:bsd-2 ; libs/optional/tests/catch.hpp
+ license:lgpl2.1+)))) ; libs/quazip