summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm29
1 files changed, 20 insertions, 9 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 9a36ffbb31..c519ca59e7 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +46,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages linux) ;FIXME: for pcb
+ #:use-module (gnu packages m4)
#:use-module (gnu packages maths)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -124,13 +126,22 @@ plans and designs.")
'check 'set-home
(lambda _
(setenv "HOME" (getenv "TMPDIR")))
- %standard-phases)))
+ %standard-phases
+ )
+ #:configure-flags
+ (let ((pcb (assoc-ref %build-inputs "pcb")))
+ (list (string-append "--with-pcb-datadir=" pcb "/share")
+ (string-append "--with-pcb-lib-path="
+ pcb "/share/pcb/pcblib-newlib:"
+ pcb "/share/pcb/newlib")))))
(inputs
`(("glib" ,glib)
("gtk" ,gtk+-2)
("guile" ,guile-2.0)
("desktop-file-utils" ,desktop-file-utils)
- ("shared-mime-info" ,shared-mime-info)))
+ ("shared-mime-info" ,shared-mime-info)
+ ("m4" ,m4)
+ ("pcb" ,pcb)))
(native-inputs
`(("pkg-config" ,pkg-config)
("perl" ,perl))) ; for tests
@@ -221,8 +232,8 @@ optimizer; and it can produce photorealistic and design review images.")
(modules '((guix build utils)
(guix build download)
(guix ftp-client)))
- (patches (list (search-patch "fastcap-mulSetup.patch")
- (search-patch "fastcap-mulGlobal.patch")))))
+ (patches (search-patches "fastcap-mulSetup.patch"
+ "fastcap-mulGlobal.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("texlive" ,texlive)
@@ -318,11 +329,11 @@ multipole-accelerated algorithm.")
"-" version ".tar.z"))
(sha256
(base32 "1a06xyyd40zhknrkz17xppl2zd5ig4w9g1grc8qrs0zqqcl5hpzi"))
- (patches (list (search-patch "fasthenry-spAllocate.patch")
- (search-patch "fasthenry-spBuild.patch")
- (search-patch "fasthenry-spUtils.patch")
- (search-patch "fasthenry-spSolve.patch")
- (search-patch "fasthenry-spFactor.patch")))))
+ (patches (search-patches "fasthenry-spAllocate.patch"
+ "fasthenry-spBuild.patch"
+ "fasthenry-spUtils.patch"
+ "fasthenry-spSolve.patch"
+ "fasthenry-spFactor.patch"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("CC=gcc" "RM=rm" "SHELL=sh" "all")