summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm19
1 files changed, 4 insertions, 15 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 141423d7bf..8e68c676ef 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1055,7 +1055,7 @@ emulation community. It provides highly accurate emulation.")
(define-public retroarch
(package
(name "retroarch")
- (version "1.7.3")
+ (version "1.7.4")
(source
(origin
(method url-fetch)
@@ -1063,7 +1063,7 @@ emulation community. It provides highly accurate emulation.")
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1si78dbwbsq4i0r42q94nmlpaxdyqch113nxavdprf4vc1224356"))))
+ (base32 "0h6y2hpjg4b470jvn9ghwp0k3a527sbb6xhia17frlm9w9v5028w"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no tests
@@ -1175,7 +1175,7 @@ play them on systems for which they were never designed!")
(define-public mame
(package
(name "mame")
- (version "0.200")
+ (version "0.201")
(source
(origin
(method git-fetch)
@@ -1185,7 +1185,7 @@ play them on systems for which they were never designed!")
(file-name (git-file-name name version))
(sha256
(base32
- "0ddw8635hdm21lgpf13k1vhfywy3460rwciv93vrqmpkq2dvpmib"))
+ "00whiig4ld3d4fkl34q48vlf28ygvvp5g7fp0rb5n31ymhl4kajk"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.
@@ -1211,17 +1211,6 @@ play them on systems for which they were never designed!")
#:tests? #f ;no test in regular release
#:phases
(modify-phases %standard-phases
- ;; Add missing include lines for "fmin" and "ceil" functions.
- ;; Reported upstream. Will be fixed in 0.201.
- (add-after 'unpack 'add-missing-include
- (lambda _
- (substitute* "src/devices/cpu/mips/mips3.cpp"
- (("#include \"ps2vu.h\"" all)
- (string-append all "\n#include <cmath>")))
- (substitute* "src/devices/cpu/mips/ps2vif1.cpp"
- (("#include \"ps2vif1.h\"" all)
- (string-append all "\n#include <cmath>")))
- #t))
(delete 'configure)
(add-after 'build 'build-documentation
(lambda _ (invoke "make" "-C" "docs" "man" "info")))