summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm159
1 files changed, 142 insertions, 17 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 0011ee057b..7a5bef2a70 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
-;;; Copyright © 2017 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2017, 2018 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 George Clemmer <myglc2@gmail.com>
;;; Copyright © 2017 Feng Shu <tumashu@163.com>
@@ -29,9 +29,11 @@
;;; Copyright © 2017, 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2017, 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018 Sohom Bhattacharjee <soham.bhattacharjee15@gmail.com>
+;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -99,6 +101,7 @@
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gd)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages password-utils)
#:use-module (guix utils)
#:use-module (srfi srfi-1)
#:use-module (ice-9 match))
@@ -383,7 +386,7 @@ when typing parentheses directly or commenting out code line by line.")
(define-public git-modes
(package
(name "emacs-git-modes")
- (version "1.2.6")
+ (version "1.2.7")
(source (origin
(method url-fetch)
(uri (string-append
@@ -392,7 +395,7 @@ when typing parentheses directly or commenting out code line by line.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "18z04wn5ird9l0h6n6x97v0kyzdj73832bj9qakm3fjjl7vcn0pw"))))
+ "1mzl70s0xyysnjq1j10mc5vn9i022n5vd82kxsgp4xxqq7gc4qnx"))))
(build-system emacs-build-system)
(home-page "https://github.com/magit/git-modes")
(synopsis "Emacs major modes for Git configuration files")
@@ -3911,7 +3914,7 @@ If you want to mark a folder manually as a project just create an empty
(define-public emacs-elfeed
(package
(name "emacs-elfeed")
- (version "2.2.0")
+ (version "2.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/skeeto/elfeed/archive/"
@@ -3919,7 +3922,7 @@ If you want to mark a folder manually as a project just create an empty
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0d7i93l3b0ck3iad9ddqp7sqa8w16hnamrby8bwvl316rqk4lzlf"))))
+ "1fd1mx0q1qb9vgdzls5ppxfriyid48blg8smgjspiazp7kxakzxv"))))
(build-system emacs-build-system)
(arguments
`(#:phases
@@ -4164,7 +4167,7 @@ the file buffer.")
(define-public emacs-helm
(package
(name "emacs-helm")
- (version "2.8.5")
+ (version "2.9.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4173,7 +4176,7 @@ the file buffer.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "15xlnjm9rsbn0xq7xc09y52h2kn41zwn7ldryammf6i46wl02kq3"))))
+ "1798gn0za11cxdbi436javfczv4abniccxcl0jppl463r8lzb8is"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-async" ,emacs-async)
@@ -4193,7 +4196,7 @@ not tied in the trap of backward compatibility.")
(define-public emacs-helm-swoop
(package
(name "emacs-helm-swoop")
- (version "1.7.2")
+ (version "1.7.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4203,7 +4206,7 @@ not tied in the trap of backward compatibility.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1z34pfi0gsk054pxr906ilaalaw0xz3s536163gf9ykkwmc2356d"))))
+ "1ssivsjzlnkg049cg993l8fp09l5nhpz6asj7w5c91zp5kpc6fh7"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-helm" ,emacs-helm)))
@@ -4511,14 +4514,14 @@ passive voice.")
(name "emacs-org")
;; emacs-org-contrib inherits from this package. Please update its sha256
;; checksum as well.
- (version "20180327")
+ (version "9.1.9")
(source (origin
(method url-fetch)
- (uri (string-append "https://orgmode.org/elpa/org-"
+ (uri (string-append "http://elpa.gnu.org/packages/org-"
version ".tar"))
(sha256
(base32
- "0xmlzlxf15996sd3gj3naiz383d17ngjd9963p4h9kssrkjlwljy"))))
+ "16yr0srfzsrzv2b1f2wjk8gb2pyhsgj2hxbscixirkxqz674c5cl"))))
(build-system emacs-build-system)
(home-page "https://orgmode.org/")
(synopsis "Outline-based notes management and organizer")
@@ -4532,13 +4535,14 @@ reproducible research.")
(package
(inherit emacs-org)
(name "emacs-org-contrib")
+ (version "20180327")
(source (origin
(method url-fetch)
(uri (string-append "https://orgmode.org/elpa/org-plus-contrib-"
- (package-version emacs-org) ".tar"))
+ version ".tar"))
(sha256
(base32
- "1nqn7m1x9w5y356ylv5hia6v62pqfz9g3rzjbiffjxyyc34xvpfm"))))
+ "1y1nn0bxnh9y4a3zrqng8n639j5da5387q2314sr3a8ggy1nb93s"))))
(arguments
`(#:modules ((guix build emacs-build-system)
(guix build utils)
@@ -4559,8 +4563,7 @@ reproducible research.")
string=? contrib-files org+contrib-files)))
(with-directory-excursion
(string-append
- out "/share/emacs/site-lisp/guix.d/org-contrib-"
- ,(package-version emacs-org))
+ out "/share/emacs/site-lisp/guix.d/org-contrib-" ,version)
(for-each delete-file duplicates))
#t))))))
(propagated-inputs
@@ -7425,3 +7428,125 @@ the same values you get in a terminal.")
"Deft is an Emacs mode for quickly browsing, filtering, and editing
directories of plain text notes, inspired by Notational Velocity.")
(license license:bsd-3)))
+
+(define-public emacs-anzu
+ (package
+ (name "emacs-anzu")
+ (version "0.62")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/syohex/emacs-anzu/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16cg3897x5znbmgk7sdy0qyd0fbic9dmmz0dchq2vz5z29yhg4cz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/syohex/emacs-anzu")
+ (synopsis "Show number of matches in mode-line while searching")
+ (description
+ "Anzu provides a minor mode which displays \"current match/total
+matches\" in the mode line in various search modes. This is an Emacs port of
+Anzu.zim.")
+ (license license:gpl3+)))
+
+(define-public emacs-emmet-mode
+ (package
+ (name "emacs-emmet-mode")
+ (version "1.0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/smihica/emmet-mode"
+ "/archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0g3p22yabfcp98cfv9dgl9il2m2pd53isq2q11vb3s7qyn31f7zj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/smihica/emmet-mode")
+ (synopsis "Unofficial Emmet's support for Emacs")
+ (description
+ "Unfold CSS-selector-like expressions to markup. It is intended to be
+used with SGML-like languages: XML, HTML, XHTML, XSL, etc.")
+ (license license:gpl3+)))
+
+(define-public emacs-password-store
+ (package
+ (name "emacs-password-store")
+ (version "1.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://git.zx2c4.com/password-store/snapshot/"
+ "password-store-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0scqkpll2q8jhzcgcsh9kqz0gwdpvynivqjmmbzax2irjfaiklpn"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'extract-el-file
+ (lambda _
+ (copy-file "contrib/emacs/password-store.el" "password-store.el")
+ (delete-file-recursively "contrib")
+ (delete-file-recursively "man")
+ (delete-file-recursively "src")
+ (delete-file-recursively "tests"))))))
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)
+ ("password-store" ,password-store)))
+ (home-page "https://git.zx2c4.com/password-store/tree/contrib/emacs")
+ (synopsis "Password store (pass) support for Emacs")
+ (description
+ "This package provides functions for working with pass (\"the
+standard Unix password manager\").")
+ (license license:gpl2+)))
+
+(define-public emacs-pass
+ (package
+ (name "emacs-pass")
+ (version "1.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/NicolasPetton/pass/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0zlx9v6z0q3w9qhq9bq6vb7sli4c9x7qccm2wq55j0nw7bwy2yvj"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-password-store" ,emacs-password-store)
+ ("emacs-f" ,emacs-f)))
+ (home-page "https://github.com/NicolasPetton/pass")
+ (synopsis "Major mode for @file{password-store.el}")
+ (description "This is a major mode for managing password-store (pass)
+keychains. The keychain entries are displayed in a directory-like structure
+and can be consulted and modified.")
+ (license license:gpl3+)))
+
+(define-public emacs-evil-anzu
+ (package
+ (name "emacs-evil-anzu")
+ (version "0.03")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/syohex/emacs-evil-anzu"
+ "/archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "032hh2946z529cizqsg8pm6cpn5qdj8lfk3qskmx6xv3g2ra56ns"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-evil" ,emacs-evil)
+ ("emacs-anzu" ,emacs-anzu)))
+ (home-page "https://github.com/syohex/emacs-evil-anzu")
+ (synopsis "Anzu for evil-mode")
+ (description "@code{anzu} provides a minor mode that displays the current
+match and total match information in the mode-line in various search modes.")
+ (license license:gpl3+)))