summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm47
1 files changed, 46 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c2c162c75c..da366441bd 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3773,7 +3773,7 @@ programming language.")
texlive-latex-seminar
texlive-latex-hyperref
texlive-tex-texinfo)))))
- (home-page "http://ess.r-project.org/")
+ (home-page "https://ess.r-project.org/")
(synopsis "Emacs mode for statistical analysis programs")
(description "Emacs Speaks Statistics (ESS) is an add-on package for GNU
Emacs. It is designed to support editing of scripts and interaction with
@@ -7361,3 +7361,48 @@ highlighting and indentation support.")
@uref{https://www.terraform.io/, Terraform} configuration files. Most of the
functionality is inherited from @code{hcl-mode}.")
(license license:gpl3+)))
+
+(define-public emacs-exec-path-from-shell
+ (package
+ (name "emacs-exec-path-from-shell")
+ (version "1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://stable.melpa.org/packages/exec-path-from-shell-"
+ version ".el"))
+ (sha256
+ (base32
+ "03qjgb81cq1l3j54lvlf98r75vmmgd06mj6qh5wa6mz4xzp4w26r"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/purcell/exec-path-from-shell")
+ (synopsis "Get environment variables such as @var{PATH} from the shell")
+ (description
+ "This library allows the user to set Emacs @var{exec-path} and @var{PATH}
+from the shell @var{PATH}, so that @code{shell-command}, @code{compile} and
+the like work as expected on systems on which Emacs is not guaranteed to
+inherit a login shell's environment variables. It also allows other
+environment variables to be retrieved from the shell, so that Emacs will see
+the same values you get in a terminal.")
+ (license license:gpl3+)))
+
+(define-public emacs-deft
+ (package
+ (name "emacs-deft")
+ (version "0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://stable.melpa.org/packages/deft-"
+ version ".el"))
+ (sha256
+ (base32
+ "1vb9cjxskc7c0yyf9pvxy1fzypg1vrcgwnjz0m3hslinsgdyig58"))))
+ (build-system emacs-build-system)
+ (home-page "https://jblevins.org/projects/deft/")
+ (synopsis "Quickly browse, filter, and edit plain text notes")
+ (description
+ "Deft is an Emacs mode for quickly browsing, filtering, and editing
+directories of plain text notes, inspired by Notational Velocity.")
+ (license license:bsd-3)))