aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm297
1 files changed, 219 insertions, 78 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 29b4487d05..5d8aa0e863 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16,9 +16,9 @@
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2016, 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016, 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
-;;; Copyright © 2017, 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2017, 2018, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2018, 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2017, 2018 Kyle Meyer <kyle@kyleam.com>
@@ -3078,7 +3078,7 @@ in @code{html-mode}.")
(define-public emacs-slime
(package
(name "emacs-slime")
- (version "2.22")
+ (version "2.23")
(source
(origin
(file-name (string-append name "-" version ".tar.gz"))
@@ -3088,7 +3088,7 @@ in @code{html-mode}.")
version ".tar.gz"))
(sha256
(base32
- "07vaib1n4zyh5yy30gdpq0bc5cv6w84piml5b3mfc9ibjhaykkms"))))
+ "01gkrqfpifcx1vipwrbhns2r4s8izp3z1w4p41azc943s1a2d5nc"))))
(build-system emacs-build-system)
(native-inputs
`(("texinfo" ,texinfo)))
@@ -4000,8 +4000,8 @@ navigate code in a tree-like fashion.")
(define-public emacs-lispy
;; Release 0.26.0 was almost 3 years ago, and there have been ~772 commits
;; since.
- (let ((commit "c2a358a7a15fcf056a5b7461a8e690b481b03b80")
- (revision "0"))
+ (let ((commit "f94cfc6b8f9c3afe7d028c366928049c011023de")
+ (revision "1"))
(package
(name "emacs-lispy")
(version (git-version "0.26.0" revision commit))
@@ -4011,7 +4011,7 @@ navigate code in a tree-like fashion.")
(uri (git-reference (url home-page) (commit commit)))
(sha256
(base32
- "1g6756qqx2n4cx8jac6mlwayilsiyc5rz8nrqjnywvzc75xdinjd"))
+ "1bm2cpwizg1qfpm377gpx1af1hm5maw69if1csnk5vwaphmv8c4g"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(propagated-inputs
@@ -4031,10 +4031,8 @@ S-expression.")
(license license:gpl3+))))
(define-public emacs-lispyville
- ;; Later versions need a more recent Evil, with an evil-define-key*
- ;; supporting nil for the state.
- (let ((commit "b4291857ed6a49a67c4ea77522889ce51fb171ab")
- (revision "0"))
+ (let ((commit "d28b937f0cabd8ce61e2020fe9a733ca80d82c74")
+ (revision "1"))
(package
(name "emacs-lispyville")
(version (git-version "0.1" revision commit))
@@ -4044,7 +4042,7 @@ S-expression.")
(uri (git-reference (url home-page) (commit commit)))
(sha256
(base32
- "095zibzc3naknahdrnb59g9rbljy8wz9rkc7rf8avb3wxlwvxhm3"))
+ "0f6srwj1qqkfkbmp5n5pjvi6gm7b7xav05p5hrs2i83rjrakzzqx"))
(file-name (git-file-name name version))))
(propagated-inputs
`(("emacs-evil" ,emacs-evil)
@@ -5184,35 +5182,34 @@ news items, openrc and runscripts.")
(license license:gpl2+)))
(define-public emacs-evil
- (let ((commit "230b87212c81aaa68ef5547a6b998d9c365fe139"))
- (package
- (name "emacs-evil")
- (version (git-version "1.2.13" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emacs-evil/evil")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0c9zy3bpck10gcrv79kd3h7i4ygd5bgbgy773n0lg7a2r5kwn1gx"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-undo-tree" ,emacs-undo-tree)
- ("emacs-goto-chg" ,emacs-goto-chg)))
- (home-page "https://github.com/emacs-evil/evil")
- (synopsis "Extensible Vi layer for Emacs")
- (description
- "Evil is an extensible vi layer for Emacs. It emulates the
+ (package
+ (name "emacs-evil")
+ (version "1.2.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-evil/evil")
+ (commit version)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1833w397xhac5g3pp25szr2gyvclxy91aw27azvbmsx94pyk2a3q"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-undo-tree" ,emacs-undo-tree)
+ ("emacs-goto-chg" ,emacs-goto-chg)))
+ (home-page "https://github.com/emacs-evil/evil")
+ (synopsis "Extensible Vi layer for Emacs")
+ (description
+ "Evil is an extensible vi layer for Emacs. It emulates the
main features of Vim, and provides facilities for writing custom
extensions.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-evil-collection
- (let ((commit "4e1f0e0b17153d460805a0da90d6191d66b2673d")
- (revision "5"))
+ (let ((commit "0cfdf4ecf0420aac2a9dd29ff7b54067c3433d71")
+ (revision "6"))
(package
(name "emacs-evil-collection")
(version (git-version "0.0.1" revision commit))
@@ -5224,7 +5221,7 @@ extensions.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "11d5ppdnb2y2mwsdd9g62h7zds962kw3nss89zv5iwgcf9f1fb5x"))))
+ "1igsvgxvij918myc397cjhfybmm11znc7961vnbcd5xlviq2p01y"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-evil" ,emacs-evil)))
@@ -5349,14 +5346,14 @@ passive voice.")
(name "emacs-org")
;; emacs-org-contrib inherits from this package. Please update its sha256
;; checksum as well.
- (version "9.2")
+ (version "9.2.1")
(source (origin
(method url-fetch)
(uri (string-append "http://elpa.gnu.org/packages/org-"
version ".tar"))
(sha256
(base32
- "14ydwh2r360fpi6v2g9rgf0zazy2ddq1pcdxvzn73h65glnnclz9"))))
+ "0ggca29pyksvfblyd2ciqhgi392wlqx0nmph7ck4m5wbzmk2qnry"))))
(build-system emacs-build-system)
(home-page "https://orgmode.org/")
(synopsis "Outline-based notes management and organizer")
@@ -5370,14 +5367,14 @@ programming and reproducible research.")
(package
(inherit emacs-org)
(name "emacs-org-contrib")
- (version "20181230")
+ (version "20190203")
(source (origin
(method url-fetch)
(uri (string-append "https://orgmode.org/elpa/org-plus-contrib-"
version ".tar"))
(sha256
(base32
- "0gibwcjlardjwq19bh0zzszv0dxxlml0rh5iikkcdynbgndk1aa1"))))
+ "060rm62p1660n9f6i5w8l932w7gn5ign93q92gva4jy4bkmvczyb"))))
(arguments
`(#:modules ((guix build emacs-build-system)
(guix build utils)
@@ -6959,7 +6956,9 @@ Emacs.")
(modify-phases %standard-phases
(add-after 'install 'install-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
+ (let ((out (assoc-ref outputs "out"))
+ (source-directory (string-append
+ (getenv "TMPDIR") "/source")))
(substitute* "bin/ert-runner"
(("ERT_RUNNER=\"\\$\\(dirname \\$\\(dirname \\$0\\)\\)")
(string-append "ERT_RUNNER=\"" out
@@ -6968,7 +6967,10 @@ Emacs.")
(install-file "bin/ert-runner" (string-append out "/bin"))
(wrap-program (string-append out "/bin/ert-runner")
(list "EMACSLOADPATH" ":" 'prefix
- (string-split (getenv "EMACSLOADPATH") #\:)))
+ ;; Do not capture the transient source directory in
+ ;; the wrapper.
+ (delete source-directory
+ (string-split (getenv "EMACSLOADPATH") #\:))))
#t))))
#:include (cons* "^reporters/.*\\.el$" %default-include)))
(home-page "https://github.com/rejeep/ert-runner.el")
@@ -11305,39 +11307,38 @@ Org-mode. It features:
(license license:gpl3+))))
(define-public emacs-fish-completion
- (let ((commit "bac15fda1392a891070574dfe5d2d50b10831e8b"))
- (package
- (name "emacs-fish-completion")
- (version (git-version "20180616" "1" commit))
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://gitlab.com/Ambrevar/emacs-fish-completion/repository/"
- "archive.tar.gz?ref="
- commit))
- (sha256
- (base32
- "093qzdrbkl7dhjk16zq8i13kh1phyigkblcfrbgbrxjqd2ndrfdi"))))
- (build-system emacs-build-system)
- (inputs `(("fish" ,fish)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((fish (assoc-ref inputs "fish")))
- ;; Specify the absolute file names of the various
- ;; programs so that everything works out-of-the-box.
- (emacs-substitute-variables
- "fish-completion.el"
- ("fish-completion-command"
- (string-append fish "/bin/fish")))))))))
- (home-page
- "https://gitlab.com/Ambrevar/emacs-fish-completion")
- (synopsis "Fish completion for Emacs pcomplete")
- (description
- "This package provides completion for the Fish shell to pcomplete (used
+ (package
+ (name "emacs-fish-completion")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gitlab.com/Ambrevar/emacs-fish-completion/repository/"
+ "archive.tar.gz?ref="
+ version))
+ (sha256
+ (base32
+ "1hpma1c5j50ja03ibr7h1xmyv7k8j3rbvqivad47kwqhlsgw0jk0"))))
+ (build-system emacs-build-system)
+ (inputs `(("fish" ,fish)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((fish (assoc-ref inputs "fish")))
+ ;; Specify the absolute file names of the various
+ ;; programs so that everything works out-of-the-box.
+ (emacs-substitute-variables
+ "fish-completion.el"
+ ("fish-completion-command"
+ (string-append fish "/bin/fish")))))))))
+ (home-page
+ "https://gitlab.com/Ambrevar/emacs-fish-completion")
+ (synopsis "Fish completion for Emacs pcomplete")
+ (description
+ "This package provides completion for the Fish shell to pcomplete (used
by shell and Eshell). You can set it up globally with:
@example
@@ -11352,7 +11353,7 @@ shell/Eshell mode hook.
The package @code{emacs-bash-completion} is an optional dependency: if available,
@code{fish-completion-complete} can be configured to fall back on bash to further
try completing. See @code{fish-completion-fallback-on-bash-p}.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-gif-screencast
(let ((commit "12b25442b97b84abae74ecb5190a9d14ff7cfe5a"))
@@ -12970,3 +12971,143 @@ comments.")
(description "This package provides an Emacs major mode which acts as a
front end to mpc, a client for the @dfn{Music Player Daemon} (MPD).")
(license license:gpl3+))))
+
+(define-public emacs-mkmcc-gnuplot-mode
+ (package
+ (name "emacs-mkmcc-gnuplot-mode")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mkmcc/gnuplot-mode")
+ (commit "601f6392986f0cba332c87678d31ae0d0a496ce7")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "14f0yh1rjqc3337j4sbqzfb7pjim2c8a7wk1a73xkrdkmjn82vgb"))))
+ (build-system emacs-build-system)
+ (home-page "https://mkmcc.github.io/software/gnuplot-mode.html")
+ (synopsis "Minimal emacs major mode for editing gnuplot scripts")
+ (description "@code{emacs-mkmcc-gnuplot-mode} is a minimal emacs major
+mode for editing gnuplot scripts. It provides syntax highlighting,
+indentation and a command to plot the file.")
+ (license license:gpl3+)))
+
+(define-public emacs-dtrt-indent
+ (package
+ (name "emacs-dtrt-indent")
+ (version "0.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jscheid/dtrt-indent")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pgf0pvqd8k4yzhdn2df9lp0y8hmlm2ccrh07jivwlccs95pcz7z"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jscheid/dtrt-indent")
+ (synopsis "Minor mode that guesses the indentation offset")
+ (description "This package provides a minor mode that guesses the
+indentation offset originally used for creating source code files and
+transparently adjusts the corresponding settings in Emacs, making it more
+convenient to edit foreign files.")
+ (license license:gpl2+)))
+
+(define-public emacs-repo
+ (package
+ (name "emacs-repo")
+ (version "0.1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/canatella/repo-el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rbvcvm7bfr6ncji7cllfxyyr6x7n9fx863byp243phsj3n93adz"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("emacs-el-mock" ,emacs-el-mock)
+ ("ert-runner" ,emacs-ert-runner)))
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("magit" ,emacs-magit)))
+ (home-page "https://github.com/canatella/repo-el")
+ (synopsis "Emacs interface for the Google Repo tool")
+ (description "This package provides integration of the Google Repo tool
+with emacs. It displays the output of the @code{repo status} command in a
+buffer and launches Magit from the status buffer for the project at point.")
+ (license license:gpl3+)))
+
+(define-public emacs-alect-themes
+ (package
+ (name "emacs-alect-themes")
+ (version "0.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alezost/alect-themes")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nffxpdm0sa7bynwi0rmlwpc4qmvbda5ankhzz7fmk4ap9fkjxv9"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/alezost/alect-themes")
+ (synopsis "Low contrast, light, dark and black color theme for Emacs")
+ (description "@code{emacs-alect-themes} provides configurable light, dark
+and black color themes for Emacs. The themes are intended to be used with
+GUI.")
+ (license license:gpl3+)))
+
+(define-public emacs-google-c-style
+ (let ((commit "6271f3f473ceb3a7fef99388a3040903b1a145f1")
+ (revision "0"))
+ (package
+ (name "emacs-google-c-style")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/styleguide")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jghyyasdl15c4gaqaxmdn43am63k6bykn5ab83f1ahv9zi1krxk"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/google/styleguide")
+ (synopsis "Emacs settings file for Google C/C++ style")
+ (description "@code{emacs-google-c-style} provides an Emacs settings
+file for Google C and C++ style.")
+ (license license:gpl1+))))
+
+(define-public emacs-redshank
+ (let ((commit "f98e68f532e622bcd464292ca4a9cf5fbea14ebb")
+ (revision "1"))
+ (package
+ (name "emacs-redshank")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://www.foldr.org/~michaelw/projects/redshank.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jdkgvd5xy9hl5q611jwah2n05abjp7qcy9sj4k1z11x0ii62b6p"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-paredit" ,emacs-paredit)))
+ (home-page "http://www.foldr.org/~michaelw/emacs/redshank/")
+ (synopsis "Common Lisp Editing Extensions (for Emacs)")
+ (description "Redshank is a collection of code-wrangling Emacs macros
+mostly geared towards Common Lisp, but some are useful for other Lisp
+dialects, too. Redshank's code transformations aim to be expression-based (as
+opposed to character-based).")
+ (license license:gpl1+))))