summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm248
1 files changed, 179 insertions, 69 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9870964ec0..e834dfffb3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -51,7 +51,7 @@
;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
-;;; Copyright © 2019 Amin Bandali <mab@gnu.org>
+;;; Copyright © 2019, 2020 Amin Bandali <mab@gnu.org>
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
@@ -8053,14 +8053,13 @@ passive voice.")
(name "emacs-org")
;; emacs-org-contrib inherits from this package. Please update it as
;; well.
- (version "9.3.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://elpa.gnu.org/packages/org-"
- version ".tar"))
- (sha256
- (base32
- "1n79h6ihhsaxxbnl9hw511aav0215m3pa51sa5fh3ddknjfplian"))))
+ (version "9.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/org-" version ".tar"))
+ (sha256
+ (base32 "1275s3hzyka2wwxl6nc2sndnwyl7kbc1nnl0hrznxb3wpy2abfd6"))))
(build-system emacs-build-system)
(home-page "https://orgmode.org/")
(synopsis "Outline-based notes management and organizer")
@@ -8074,14 +8073,14 @@ programming and reproducible research.")
(package
(inherit emacs-org)
(name "emacs-org-contrib")
- (version "20191226")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://orgmode.org/elpa/"
- "org-plus-contrib-" version ".tar"))
- (sha256
- (base32
- "08h6qiplvm7rvrb1pv2arwdlv6p31p0a6h0fk64kb79g6br8rk8i"))))
+ (version "20200126")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://orgmode.org/elpa/"
+ "org-plus-contrib-" version ".tar"))
+ (sha256
+ (base32 "08yik0i8ya2x5j4vsnwxdcdlcxbiq58lvy30vcbdbf0hqrd40kjv"))))
(arguments
`(#:modules ((guix build emacs-build-system)
(guix build utils)
@@ -12357,7 +12356,7 @@ into sections while preserving the structure imposed by any timestamps.")
(define-public emacs-org-make-toc
(package
(name "emacs-org-make-toc")
- (version "0.3")
+ (version "0.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -12366,7 +12365,7 @@ into sections while preserving the structure imposed by any timestamps.")
(file-name (git-file-name name version))
(sha256
(base32
- "0syhj8q4pv33xgl5qa6x27yhwqvfhffw5xqp819hj4qs1ddlc7j5"))))
+ "0348iq3bc3rxs5bqdvskyly4agqxiapamqkfm0323620kxl70agw"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-org" ,emacs-org)
@@ -15378,56 +15377,54 @@ try completing. See @code{fish-completion-fallback-on-bash-p}.")
(license license:gpl3+)))
(define-public emacs-gif-screencast
- (let ((commit "248d1e158405e6cba2c65ecaed40e2c59b089cd8")
- (revision "2"))
- (package
- (name "emacs-gif-screencast")
- (version (git-version "1.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/Ambrevar/emacs-gif-screencast.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "19xqi5mgalnnhb4hw0fh7py2s2dllldx1xxbhwhknkdpifai8hl8"))))
- (build-system emacs-build-system)
- (inputs
- `(("scrot" ,scrot)
- ("imagemagick" ,imagemagick)
- ("gifsicle" ,gifsicle)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((scrot (assoc-ref inputs "scrot"))
- (imagemagick (assoc-ref inputs "imagemagick"))
- (gifsicle (assoc-ref inputs "gifsicle")))
- (make-file-writable "gif-screencast.el")
- ;; Specify the absolute file names of the various
- ;; programs so that everything works out-of-the-box.
- (emacs-substitute-variables
- "gif-screencast.el"
- ("gif-screencast-program"
- (string-append scrot "/bin/scrot"))
- ("gif-screencast-convert-program"
- (string-append imagemagick "/bin/convert"))
- ("gif-screencast-cropping-program"
- (string-append imagemagick "/bin/mogrify"))
- ("gif-screencast-optimize-program"
- (string-append gifsicle "/bin/gifsicle")))))))))
- (home-page
- "https://gitlab.com/Ambrevar/emacs-gif-screencast")
- (synopsis "One-frame-per-action GIF recording")
- (description
- "Call @code{gif-screencast} to start a recording.
+ (package
+ (name "emacs-gif-screencast")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/Ambrevar/emacs-gif-screencast.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g1by8lvf8c9vzm4wwsi5kp285kaj0ahsl54048ympin4pi0njw9"))))
+ (build-system emacs-build-system)
+ (inputs
+ `(("scrot" ,scrot)
+ ("imagemagick" ,imagemagick)
+ ("gifsicle" ,gifsicle)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((scrot (assoc-ref inputs "scrot"))
+ (imagemagick (assoc-ref inputs "imagemagick"))
+ (gifsicle (assoc-ref inputs "gifsicle")))
+ (make-file-writable "gif-screencast.el")
+ ;; Specify the absolute file names of the various
+ ;; programs so that everything works out-of-the-box.
+ (emacs-substitute-variables
+ "gif-screencast.el"
+ ("gif-screencast-program"
+ (string-append scrot "/bin/scrot"))
+ ("gif-screencast-convert-program"
+ (string-append imagemagick "/bin/convert"))
+ ("gif-screencast-cropping-program"
+ (string-append imagemagick "/bin/mogrify"))
+ ("gif-screencast-optimize-program"
+ (string-append gifsicle "/bin/gifsicle")))))))))
+ (home-page
+ "https://gitlab.com/Ambrevar/emacs-gif-screencast")
+ (synopsis "One-frame-per-action GIF recording")
+ (description
+ "Call @code{gif-screencast} to start a recording.
A screenshot is taken for every user action. Call
@code{gif-screencast-stop} (<f9> by default) to finish recording and create
the GIF result.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-google-translate
(package
@@ -20209,7 +20206,7 @@ Emacs that integrate with major modes like Org-mode.")
(define-public emacs-modus-themes
(package
(name "emacs-modus-themes")
- (version "0.3.0")
+ (version "0.4.0")
(source
(origin
(method git-fetch)
@@ -20218,8 +20215,7 @@ Emacs that integrate with major modes like Org-mode.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "1xrrjhpdxi9bgx877gvq8xrc2ph5qp9y5j3ssdphy333x9km1px1"))))
+ (base32 "0c4y3y9mjf6x2b9087fk6nkxvgvm9f5l1p2vdwqny80vp4krsb8r"))))
(build-system emacs-build-system)
(home-page "https://gitlab.com/protesilaos/modus-themes")
(synopsis "Emacs themes designed for colour-contrast accessibility")
@@ -21127,3 +21123,117 @@ pattern guessed from thing under current cursor position.
mercury-mode provided by Emacs as a wrapper around prolog-mode.")
(home-page "https://github.com/ahungry/metal-mercury-mode")
(license license:gpl3+))))
+
+(define-public emacs-boxquote
+ ;; The following commit is 2.1 release with a switch to GPL3+ license.
+ (let ((commit "7e47e0e2853bc1215739b2e28f260e9eed93b2c5")
+ (revision "0"))
+ (package
+ (name "emacs-boxquote")
+ (version (git-version "2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/davep/boxquote.el.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1aqhg24gajvllbqxb0zxrnx6sddas37k2ldfinqyszd856sjhsg3"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/davep/boxquote.el")
+ (synopsis "Quote text with different kinds of boxes")
+ (description "@code{boxquote} provides a set of functions for using
+a text quoting style that partially boxes in the left hand side of an area of
+text, such a marking style might be used to show externally included text or
+example code.")
+ (license license:gpl3+))))
+
+(define-public emacs-company-ebdb
+ (package
+ (name "emacs-company-ebdb")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "company-ebdb-" version ".el"))
+ (sha256
+ (base32 "146qpiigz12zp1823ggxfrx090g0mxs7gz1ba7sa0iq6ibgzwwm9"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-company" ,emacs-company)))
+ (home-page "https://elpa.gnu.org/packages/company-ebdb.html")
+ (synopsis "Company completion backend for EBDB in Message mode")
+ (description "@code{company-ebdb} provides Company mode integration for
+EBDB. It is copied more or less intact from @code{company-bbdb}, originally
+by Jan Tatarik.")
+ (license license:gpl3+)))
+
+(define-public emacs-mwim
+ ;; Use the latest commit not in a release version as of yet, since it
+ ;; contains a bug fix for the cases where `comment-start-skip' is nil.
+ (let ((commit "b4f3edb4c0fb8f8b71cecbf8095c2c25a8ffbf85")
+ (revision "0"))
+ (package
+ (name "emacs-mwim")
+ (version (git-version "0.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alezost/mwim.el.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l3k611gp9g2x2vfmh92wnhnda81dslpwwpb8mxmzk308man77ya"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/alezost/mwim.el")
+ (synopsis "Move to the beginning/end of line, code or comment")
+ (description "@code{mwim} provides several commands to switch between
+various line positions, like moving to the beginning/end of code, line, or
+comment.")
+ (license license:gpl3+))))
+
+(define-public emacs-delight
+ (package
+ (name "emacs-delight")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "delight-" version ".el"))
+ (sha256
+ (base32 "0kzlvzwmn6zj0874086q2xw0pclyi7wlkq48zh2lkd2796xm8vw7"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/delight.html")
+ (synopsis "Dimmer switch for your mode-line lighter text")
+ (description "@code{delight} enables customizing or hiding the
+mode-line text (lighter) of major and minor modes.")
+ (license license:gpl3+)))
+
+(define-public emacs-unkillable-scratch
+ ;; Use the latest (unreleased) commit as of now, since it contains a handy
+ ;; `unkillable-scratch-do-not-reset-scratch-buffer' customization to not
+ ;; repopulate the scratch buffer with `initial-scratch-message'.
+ (let ((commit "b24c2a760529833f230c14cb02ff6e7ec92288ab")
+ (revision "0"))
+ (package
+ (name "emacs-unkillable-scratch")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/EricCrosson/unkillable-scratch.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13wjbcxr3km4s96yhpavgs5acs5pvqv3ih1p84diqb3x3i6wd4pa"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/EricCrosson/unkillable-scratch")
+ (synopsis "Prevents the *scratch* buffer from being killed")
+ (description "@code{unkillable-scratch} helps prevent killing buffers
+matching a given regexp.")
+ (license license:gpl2+))))