summaryrefslogtreecommitdiff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm23
1 files changed, 20 insertions, 3 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 19c42b00eb..c512a9803b 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@
#:use-module (guix build-system cmake)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages python)
#:use-module (gnu packages bison)
@@ -123,7 +125,7 @@ markup) can be customized and extended by the user.")
(define-public doxygen
(package
(name "doxygen")
- (version "1.8.15")
+ (version "1.8.16")
(home-page "http://www.doxygen.nl/")
(source (origin
(method url-fetch)
@@ -134,7 +136,7 @@ markup) can be customized and extended by the user.")
".src.tar.gz")))
(sha256
(base32
- "0p94b4yb6bk2dxzs5kyl82xxgq2qakgbx5yy3ssbbadncb20x75x"))
+ "10iwv8bcz5b5cd85gg8pgn0bmyg04n9hs36xn7ggjjnvynv1z67z"))
(patches (search-patches "doxygen-test.patch"))))
(build-system cmake-build-system)
(native-inputs
@@ -145,8 +147,23 @@ markup) can be customized and extended by the user.")
(inputs
`(("bash" ,bash-minimal)))
(arguments
- `(#:test-target "tests"
+ ;; Force cmake to use iconv header from cross-libc instead of the one
+ ;; from native libc.
+ `(,@(if (%current-target-system)
+ '(#:configure-flags
+ (list (string-append "-DICONV_INCLUDE_DIR="
+ (assoc-ref %build-inputs "cross-libc")
+ "/include")))
+ '())
+ #:test-target "tests"
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'remove-git-requirement
+ (lambda _
+ ;; TODO: Remove this for > 1.8.16.
+ (substitute* "cmake/git_watcher.cmake"
+ (("Git QUIET REQUIRED")
+ "Git QUIET"))
+ #t))
(add-before 'configure 'patch-sh
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/portable.cpp"