summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 8fd29d533a..8ea9dca16a 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -519,9 +519,9 @@ project aims to bulk update given objects using one query over Django ORM.")
(replace 'check
(lambda _
;; the next version will need "make test"
- (and (zero? (system* "flake8" "contact_form"))
- (zero? (system* "coverage" "run" "contact_form/runtests.py"))
- (zero? (system* "coverage" "report" "-m" "--fail-under" "0"))))))))
+ (invoke "flake8" "contact_form")
+ (invoke "coverage" "run" "contact_form/runtests.py")
+ (invoke "coverage" "report" "-m" "--fail-under" "0"))))))
(native-inputs
`(("python-coverage" ,python-coverage)
("python-flake8" ,python-flake8)))
@@ -577,8 +577,7 @@ entries, photos, book chapters, or anything else.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (zero? (system* "./test_project/manage.py" "test")))))))
+ (lambda _ (invoke "./test_project/manage.py" "test"))))))
(propagated-inputs
`(("python-django" ,python-django)))
(native-inputs