summaryrefslogtreecommitdiff
path: root/gnu/packages/display-managers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/display-managers.scm')
-rw-r--r--gnu/packages/display-managers.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 9f8d7b8250..8e5bca64c0 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -132,16 +132,16 @@ Qt-style API for Wayland clients.")
(define-public sddm
(package
(name "sddm")
- (version "0.15.0")
+ (version "0.16.0")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/sddm/sddm"
"/releases/download/v" version "/"
- "sddm-" version ".tar.gz"))
+ "sddm-" version ".tar.xz"))
(sha256
(base32
- "0x1igkjm3k8q26xbmg0qah1fc2pn2sfc675w0xg42x7ncrdiw8d4"))))
+ "0fwf1wsdak5yglykfyq4wbx9g9gi079n8ncjrdynz17hwwiql4z9"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -337,17 +337,18 @@ GTK+, lets you select a desktop session and log in to it.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(arguments
- '(#:phases (alist-cons-before
- 'configure 'set-new-etc-location
- (lambda _
- (substitute* "CMakeLists.txt"
- (("/etc")
- (string-append (assoc-ref %outputs "out") "/etc"))
- (("install.*systemd.*")
- ;; The build system's logic here is: if "Linux", then
- ;; "systemd". Strip that.
- "")))
- %standard-phases)
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-new-etc-location
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("/etc")
+ (string-append (assoc-ref %outputs "out") "/etc"))
+ (("install.*systemd.*")
+ ;; The build system's logic here is: if "Linux", then
+ ;; "systemd". Strip that.
+ ""))
+ #t)))
#:configure-flags '("-DUSE_PAM=yes"
"-DUSE_CONSOLEKIT=no")
#:tests? #f))