summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm25
1 files changed, 23 insertions, 2 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 030fabfa58..d19f8e873e 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,6 +31,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
+ #:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages docbook)
@@ -214,7 +216,7 @@ to recover data more efficiently by only reading the necessary blocks.")
`(#:make-flags (list (string-append "PREFIX=" %output)
"CC=gcc")))
(native-inputs
- `(("xxd" ,vim))) ; for tests
+ `(("xxd" ,xxd))) ; for tests
(home-page "https://github.com/dosfstools/dosfstools")
(synopsis "Utilities for making and checking MS-DOS FAT file systems")
(description
@@ -344,7 +346,7 @@ and can dramatically shorten the lifespan of the drive if left unchecked.")
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)))
- (home-page "https://sourceforge.net/projects/gparted/")
+ (home-page "https://gparted.org/")
(synopsis "Partition editor to graphically manage disk partitions")
(description "GParted is a GNOME partition editor for creating,
reorganizing, and deleting disk partitions. It uses libparted from the parted
@@ -353,6 +355,25 @@ permit managing file systems not included in libparted.")
;; The home page says GPLv2, but the source code says GPLv2+.
(license license:gpl2+)))
+(define-public pydf
+ (package
+ (name "pydf")
+ (version "12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pydf" version))
+ (sha256
+ (base32
+ "0f8ly8xyp93i2hm9c0qjqd4y86nz73axw2f09z01mszwmg1sfivz"))))
+ (build-system python-build-system)
+ (home-page "http://kassiopeia.juls.savba.sk/~garabik/software/pydf/")
+ (synopsis "Colourised @command{df} clone")
+ (description "All-singing, all-dancing, fully colourised @command{df} clone
+written in Python. It displays the amount of disk space available on the
+mounted filesystems, using different colours for different types of file
+systems. Output format is completely customizable.")
+ (license license:public-domain)))
(define-public f3
(package