summaryrefslogtreecommitdiff
path: root/gnu/packages/dbm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/dbm.scm')
-rw-r--r--gnu/packages/dbm.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/dbm.scm b/gnu/packages/dbm.scm
index 5191c475c2..ea812c9715 100644
--- a/gnu/packages/dbm.scm
+++ b/gnu/packages/dbm.scm
@@ -55,7 +55,7 @@
#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key target outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(doc (assoc-ref outputs "doc")))
;; '--docdir' is not honored, so we need to patch.
@@ -74,6 +74,10 @@
'("--build=aarch64-unknown-linux-gnu")
'())
+ ,@(if (%current-target-system) ; cross building
+ '((string-append "--host=" target))
+ '())
+
;; Remove 7 MiB of .a files.
"--disable-static"
@@ -134,7 +138,8 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
(sha256
(base32
"1p4ibds6z3ccy65lkmd6lm7js0kwifvl53r0fd759fjxgr917rl6"))))
- (arguments `(#:configure-flags '("--enable-libgdbm-compat")))
+ (arguments `(#:configure-flags '("--enable-libgdbm-compat"
+ "--disable-static")))
(build-system gnu-build-system)
(home-page "http://www.gnu.org.ua/software/gdbm")
(synopsis