summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm42
1 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7e4b2ff857..71ad77b9be 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -28,6 +28,7 @@
(define-module (gnu packages databases)
#:use-module (gnu packages)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages perl)
#:use-module (gnu packages language)
#:use-module (gnu packages linux)
@@ -132,16 +133,19 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
(define-public mysql
(package
(name "mysql")
- (version "5.6.25")
+ (version "5.7.11")
(source (origin
(method url-fetch)
- (uri (string-append
- "http://dev.mysql.com/get/Downloads/MySQL-"
- (version-major+minor version) "/"
- name "-" version ".tar.gz"))
+ (uri (list (string-append
+ "http://dev.mysql.com/get/Downloads/MySQL-"
+ (version-major+minor version) "/"
+ name "-" version ".tar.gz")
+ (string-append
+ "http://downloads.mysql.com/archives/get/file/"
+ name "-" version ".tar.gz")))
(sha256
(base32
- "1gbz5i1z3nswpq3q8f477vrx7g15j8n41pyb94k0jfnkhc5rq1qm"))))
+ "03hzd2ikabxhh5ch2yvml2nks2wpv3qbkqmx3520in6khypwgy2l"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
@@ -167,16 +171,11 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
"-DINSTALL_SQLBENCHDIR=")
#:phases (modify-phases %standard-phases
(add-after
- 'install 'strip-extra-references
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Strip references to GCC and other build-time
- ;; dependencies.
- (let ((out (assoc-ref outputs "out")))
- (for-each remove-store-references
- (list (string-append out "/bin/mysqlbug")
- (string-append
- out "/share/mysql/docs/INFO_BIN")))
- #t)))
+ 'unpack 'patch-boost-version
+ (lambda _
+ ;; Mysql wants boost-1.59.0 specifically
+ (substitute* "cmake/boost.cmake"
+ (("59") "60"))))
(add-after
'install 'remove-extra-binaries
(lambda* (#:key outputs #:allow-other-keys)
@@ -191,10 +190,11 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
`(("bison" ,bison)
("perl" ,perl)))
(inputs
- `(("libaio" ,libaio)
+ `(("boost" ,boost)
+ ("libaio" ,libaio)
+ ("ncurses" ,ncurses)
("openssl" ,openssl)
- ("zlib" ,zlib)
- ("ncurses" ,ncurses)))
+ ("zlib" ,zlib)))
(home-page "http://www.mysql.com/")
(synopsis "Fast, easy to use, and popular database")
(description
@@ -206,7 +206,7 @@ Language.")
(define-public mariadb
(package
(name "mariadb")
- (version "10.0.23")
+ (version "10.1.12")
(source (origin
(method url-fetch)
(uri (string-append "https://downloads.mariadb.org/f/"
@@ -214,7 +214,7 @@ Language.")
name "-" version ".tar.gz"))
(sha256
(base32
- "0x52gfxk7zr84al83x62s4gh7mbngahy1svafdkbwd18i5lysvhm"))))
+ "1rzlc2ns84x540asbkgdp9562haxhlszfpdqh64i9pz4q1m4cpvr"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags