summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm115
1 files changed, 103 insertions, 12 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 37890a91fc..20981dced1 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
@@ -18,6 +18,7 @@
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -52,6 +53,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages time)
#:use-module (gnu packages jemalloc)
#:use-module (gnu packages language)
#:use-module (gnu packages libevent)
@@ -66,6 +68,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages rdf)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages tcl)
#:use-module (gnu packages tls)
#:use-module (gnu packages xml)
@@ -75,6 +78,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix build-system ruby)
#:use-module (guix build-system cmake)
#:use-module (guix utils)
#:use-module (srfi srfi-26)
@@ -115,9 +119,9 @@
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'generate-configure
+ (add-after 'unpack 'generate-configure
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh")))))))
;; http://www.4store.org has been down for a while now.
(home-page "https://github.com/garlik/4store")
(synopsis "Clustered RDF storage and query engine")
@@ -254,6 +258,45 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
"--enable-cxx"))))
%standard-phases)))))
+(define-public es-dump-restore
+ (package
+ (name "es-dump-restore")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "es_dump_restore" version))
+ (sha256
+ (base32
+ "020yk7f1hw48clmf5501z3xv9shsdchyymcv0y2cci2c1xvr1mim"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f ;; No testsuite.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-bin-es_dump_restore
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/es_dump_restore")
+ `("GEM_PATH" ":" prefix (,(string-append
+ (getenv "GEM_PATH")
+ ":"
+ (getenv "GEM_HOME")))))
+ #t)))))
+ (propagated-inputs
+ `(("ruby-httpclient" ,ruby-httpclient)
+ ("ruby-multi-json" ,ruby-multi-json)
+ ("ruby-progress_bar" ,ruby-progress_bar)
+ ("ruby-rubyzip" ,ruby-rubyzip)
+ ("ruby-thor" ,ruby-thor)))
+ (synopsis "Utility for dumping and restoring ElasticSearch indexes")
+ (description
+ "This package provides a utility for dumping the contents of an
+ElasticSearch index to a compressed file and restoring the dumpfile back to an
+ElasticSearch server")
+ (home-page "https://github.com/patientslikeme/es_dump_restore")
+ (license license:expat)))
+
(define-public leveldb
(package
(name "leveldb")
@@ -371,12 +414,7 @@ applications.")
(for-each delete-file
(find-files (string-append out "/bin")
"_embedded$"))
- #t))))
- ;; On aarch64 the test suite runs out of memory and fails.
- ,@(if (string-prefix? "aarch64-linux"
- (or (%current-target-system) (%current-system)))
- '(#:tests? #f)
- '())))
+ #t))))))
(native-inputs
`(("bison" ,bison)
("perl" ,perl)))
@@ -474,14 +512,14 @@ as a drop-in replacement of MySQL.")
(define-public postgresql
(package
(name "postgresql")
- (version "9.6.4")
+ (version "9.6.5")
(source (origin
(method url-fetch)
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
- "04yffrrmn85k25n3nq389aa9c1j8mkimrf889kayl772h9nv2fib"))))
+ "0k3ls2x182jz6djjiqj9kycddabdl2gk1y1ajq1vipnxwfki5nh6"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-uuid=e2fs")
@@ -1568,7 +1606,7 @@ for ODBC.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autoreconf
+ (add-after 'unpack 'autoreconf
(lambda _
(zero? (system* "autoreconf" "-vfi")))))))
(home-page "http://mdbtools.sourceforge.net/")
@@ -1626,3 +1664,56 @@ Memory-Mapped Database} (LMDB), a high-performance key-value store.")
(define-public python2-lmdb
(package-with-python2 python-lmdb))
+
+(define-public python-orator
+ (package
+ (name "python-orator")
+ (version "0.9.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "orator" version))
+ (sha256
+ (base32
+ "14r58z64fdp76ixnvmi4lni762b405ynmsx6chr1qihs3yl9zn6c"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'loosen-dependencies
+ ;; Tests are not actually run since they are not included with the
+ ;; distributed package, but dependencies are checked.
+ (lambda _
+ (substitute* "setup.py"
+ ((",<.*'") "'")
+ (("flexmock==0.9.7") "flexmock")
+ ;; The pytest-mock package is out of date, so we remove minimum
+ ;; version requirement.
+ (("pytest-mock.*'") "pytest-mock'"))
+ #t)))))
+ (native-inputs
+ `(("python-pytest-mock" ,python-pytest-mock)
+ ("python-pytest" ,python-pytest-3.0)
+ ("python-flexmock" ,python-flexmock)))
+ (propagated-inputs
+ `(("python-backpack" ,python-backpack)
+ ("python-blinker" ,python-blinker)
+ ("python-cleo" ,python-cleo)
+ ("python-faker" ,python-faker)
+ ("python-inflection" ,python-inflection)
+ ("python-lazy-object-proxy" ,python-lazy-object-proxy)
+ ("python-pendulum" ,python-pendulum)
+ ("python-pyaml" ,python-pyaml)
+ ("python-pygments" ,python-pygments)
+ ("python-simplejson" ,python-simplejson)
+ ("python-six" ,python-six)
+ ("python-wrapt" ,python-wrapt)))
+ (home-page "https://orator-orm.com/")
+ (synopsis "ActiveRecord ORM for Python")
+ (description
+ "Orator provides a simple ActiveRecord-like Object Relational Mapping
+implementation for Python.")
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-orator))))))
+
+(define-public python2-orator
+ (package-with-python2 (strip-python2-variant python-orator)))