summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index bcf1864775..716c75d7f8 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2017 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
@@ -162,14 +162,14 @@ either single machines or networked clusters.")
(define-public gdbm
(package
(name "gdbm")
- (version "1.13")
+ (version "1.14.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gdbm/gdbm-"
version ".tar.gz"))
(sha256
(base32
- "0lx201q20dvc70f8a3c9s7s18z15inlxvbffph97ngvrgnyjq9cx"))))
+ "0pxwz3jlwvglq2mrbxvrjgr8pa0aj73p3v9sxmdlj570zw0gzknd"))))
(arguments `(#:configure-flags '("--enable-libgdbm-compat")))
(build-system gnu-build-system)
(home-page "http://www.gnu.org.ua/software/gdbm")
@@ -438,7 +438,8 @@ applications.")
(string-append "src/third_party/" dir)))
'("pcre-8.41" "scons-2.5.0" "snappy-1.1.3"
"valgrind-3.11.0" "wiredtiger"
- "yaml-cpp-0.5.3" "zlib-1.2.8"))))
+ "yaml-cpp-0.5.3" "zlib-1.2.8"))
+ #t))
(patches
(list
(search-patch "mongodb-support-unknown-linux-distributions.patch")))))
@@ -1006,7 +1007,7 @@ for example from a shell script.")
(define-public sqlite
(package
(name "sqlite")
- (version "3.21.0")
+ (version "3.22.0")
(source (origin
(method url-fetch)
(uri (let ((numeric-version
@@ -1018,11 +1019,11 @@ for example from a shell script.")
(map (cut string-pad <> 2 #\0)
other-digits))
6 #\0))))))
- (string-append "https://sqlite.org/2017/sqlite-autoconf-"
+ (string-append "https://sqlite.org/2018/sqlite-autoconf-"
numeric-version ".tar.gz")))
(sha256
(base32
- "1qxvzdjwzw6k0kqjfabj86rnq87xdbwbca7laxxdhnh0fmkm3pfp"))))
+ "04n6hnw2g818d7r92cp2608kd5mhzyysy83k29kbq1mp709an918"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
(arguments
@@ -1627,12 +1628,7 @@ trees (LSM), for sustained throughput under random insert workloads.")
#:configure-flags
(list (string-append "--with-libwiredtiger-prefix="
(assoc-ref %build-inputs "wiredtiger")))
- #:make-flags '("GUILE_AUTO_COMPILE=0")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _
- (invoke "sh" "bootstrap"))))))
+ #:make-flags '("GUILE_AUTO_COMPILE=0")))
;; TODO: Remove microkanren.scm when we have a separate package
;; for it.
(native-inputs
@@ -1940,10 +1936,12 @@ etc., and an SQL engine for performing simple SQL queries.")
(modules '((guix build utils)))
(snippet
;; Delete bundled lmdb source files.
- '(for-each delete-file (list "lib/lmdb.h"
- "lib/mdb.c"
- "lib/midl.c"
- "lib/midl.h")))))
+ '(begin
+ (for-each delete-file (list "lib/lmdb.h"
+ "lib/mdb.c"
+ "lib/midl.c"
+ "lib/midl.h"))
+ #t))))
(build-system python-build-system)
(inputs
`(("lmdb" ,lmdb)))