summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index a8998d803d..1ccfb9e2ac 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2012, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
@@ -148,6 +148,7 @@ and provides interfaces to the traditional file format.")
"doc")) ; 94 MiB of HTML docs
(arguments
'(#:tests? #f ; no check target available
+ #:disallowed-references ("doc")
#:phases
(alist-replace
'configure
@@ -165,6 +166,9 @@ and provides interfaces to the traditional file format.")
(string-append "CONFIG_SHELL=" (which "bash"))
(string-append "SHELL=" (which "bash"))
+ ;; Remove 7 MiB of .a files.
+ "--disable-static"
+
;; The compatibility mode is needed by some packages,
;; notably iproute2.
"--enable-compat185"
@@ -403,7 +407,7 @@ types are supported, as is encryption.")
(define-public sqlite
(package
(name "sqlite")
- (version "3.10.0")
+ (version "3.11.1")
(source (origin
(method url-fetch)
;; TODO: Download from sqlite.org once this bug :
@@ -434,7 +438,7 @@ types are supported, as is encryption.")
))
(sha256
(base32
- "0hhhv6si0pyf5i8bv7a71953m0b4gk6s3j2h09caf7vif0njkk23"))))
+ "0xs3gl3kbxqfx2ahrymgcf2n8c8sy37724jr05pncbhw4z8g2gsk"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
(arguments