summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 32509fc3fc..ccff18e632 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -152,7 +153,7 @@ tunneling, and so on.")
(define-public kurly
(package
(name "kurly")
- (version "1.1.0")
+ (version "1.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -161,19 +162,24 @@ tunneling, and so on.")
(file-name (git-file-name name version))
(sha256
(base32
- "1q192f457sjypgvwq7grrf8gq8w272p3zf1d5ppc20mriqm0mbc3"))))
+ "01kp33gvzxmk6ipz7323wqwmbc90q2mwzsjig8rzpqsm4kji5hi6"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/davidjpeacock/kurly"
#:install-source? #f
#:phases
(modify-phases %standard-phases
- (add-after 'install 'install-readme
- (lambda* (#:key outputs import-path #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (readme (string-append "src/" import-path "/README.md"))
- (misc (string-append out "/share/kurly/misc/")))
- (install-file readme misc)
+ (add-after 'install 'install-documentation
+ (lambda* (#:key import-path outputs #:allow-other-keys)
+ (let* ((source (string-append "src/" import-path))
+ (out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version))
+ (man (string-append out "/share/man/man1")))
+ (with-directory-excursion source
+ (install-file "README.md" doc)
+ (mkdir-p man)
+ (copy-file "meta/kurly.man"
+ (string-append man "/kurly.1")))
#t))))))
(inputs
`(("go-github-com-alsm-ioprogress" ,go-github-com-alsm-ioprogress)