summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 16cbdcd7df..65bc698389 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -44,12 +44,13 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages ssh)
- #:use-module (gnu packages tls))
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages web))
(define-public curl
(package
(name "curl")
- (version "7.57.0")
+ (version "7.59.0")
(replacement curl-7.60.0)
(source (origin
(method url-fetch)
@@ -57,7 +58,7 @@
version ".tar.xz"))
(sha256
(base32
- "0y3qbjjcxhcvm1yawp3spfssjbskv0g6gyzld6ckif5pf8ygvxpm"))))
+ "1z310hrjm2vmbcpkyp81dcmj9rk127zkjyawpy2pah0nz6yslkp4"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.2 MiB of man3 pages
@@ -66,6 +67,7 @@
("libidn" ,libidn)
("libssh2" ,libssh2)
("openldap" ,openldap)
+ ("nghttp2" ,nghttp2 "lib")
("zlib" ,zlib)))
(native-inputs
`(("perl" ,perl)
@@ -125,7 +127,7 @@
;; The top-level "make check" does "make -C tests quiet-test", which
;; is too quiet. Use the "test" target instead, which is more
;; verbose.
- (zero? (system* "make" "-C" "tests" "test")))))))
+ (invoke "make" "-C" "tests" "test"))))))
(synopsis "Command line tool for transferring data with URL syntax")
(description
"curl is a command line tool for transferring data with URL syntax,