summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 38e556469a..19870d9542 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -131,15 +131,16 @@ communication, encryption, decryption, signatures, etc.")
(define-public signify
(package
(name "signify")
- (version "24")
+ (version "25")
+ (home-page "https://github.com/aperezdc/signify")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/aperezdc/signify/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0594vyvkq176xxzaz9xbq8qs0xdnr8s9gkd1prblwpdvnzmw0xvc"))))
+ "0zg0rffxwj2a71s1bllhrn491xsmirg9sshpq8f3vl25lv4c2cnq"))))
(build-system gnu-build-system)
;; TODO Build with libwaive (described in README.md), to implement something
;; like OpenBSD's pledge().
@@ -159,7 +160,6 @@ communication, encryption, decryption, signatures, etc.")
(description "The signify utility creates and verifies cryptographic
signatures using the elliptic curve Ed25519. This is a Linux port of the
OpenBSD tool of the same name.")
- (home-page "https://github.com/aperezdc/signify")
;; This package includes third-party code that was originally released under
;; various non-copyleft licenses. See the source files for clarification.
(license (list license:bsd-3 license:bsd-4 license:expat license:isc
@@ -208,9 +208,9 @@ OpenBSD tool of the same name.")
(add-after 'unpack 'unpack-googletest
(lambda* (#:key inputs #:allow-other-keys)
(mkdir-p "vendor/github.com/google/googletest")
- (invoke "tar" "xvf" (assoc-ref inputs "googletest-source")
- "-C" "vendor/github.com/google/googletest"
- "--strip-components=1")))
+ (copy-recursively (assoc-ref inputs "googletest-source")
+ "vendor/github.com/google/googletest")
+ #t))
(add-before 'check 'make-unittests
(lambda _
(invoke "make" "unittests"))))))