summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm41
1 files changed, 7 insertions, 34 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7a0ea03a67..51d9363b55 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -475,31 +476,6 @@ depending on a large number of #[cfg] parameters. Structured like an
colorization.")
(license license:expat)))
-(define-public rust-clippy
- (package
- (name "rust-clippy")
- (version "0.0.302")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "clippy" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1562x3sq9mgmc8j39gd34wqm7ybrdvpmj7cc1n450gwsawayw4fr"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-term" ,rust-term))))
- (home-page "https://github.com/rust-lang/rust-clippy")
- (synopsis
- "A bunch of helpful lints to avoid common pitfalls in Rust.")
- (description
- "This package provides a bunch of helpful lints to avoid common pitfalls in Rust.")
- (license (list license:asl2.0
- license:expat))))
-
(define-public rust-cloudabi
(package
(name "rust-cloudabi")
@@ -1971,15 +1947,14 @@ file IO.")
(define-public rust-miniz-oxide
(package
(name "rust-miniz-oxide")
- (version "0.3.2")
+ (version "0.3.3")
(source
(origin
(method url-fetch)
(uri (crate-uri "miniz_oxide" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "041s41l5w7z8pkp93pdzn8rngxr93q4wxp034pr0cvc7bgway23i"))))
+ (base32 "1bmanbbcdmssfbgik3fs323g7vljc5wkjz7s61jsbbz2kg0nckrh"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -2428,15 +2403,14 @@ system for OpenSSL.")
(define-public rust-openssl-sys
(package
(name "rust-openssl-sys")
- (version "0.9.49")
+ (version "0.9.50")
(source
(origin
(method url-fetch)
(uri (crate-uri "openssl-sys" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "1168vivyqbzaxl48bvv9r1x714c03f5c1za8pv5x8fyj9gjxkypl"))))
+ (base32 "1dn3capgiz77s6rpmc2sf8gadwkmhwgfd6mw4rcnnm9jp36dqhic"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -4147,15 +4121,14 @@ or XID_Continue properties according to Unicode Standard Annex #31.")
(define-public rust-unindent
(package
(name "rust-unindent")
- (version "0.1.3")
+ (version "0.1.5")
(source
(origin
(method url-fetch)
(uri (crate-uri "unindent" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "1x21ilf78aqcq9xzb9b7i628wm10rhk0jp0chlv06rkc690l8jw3"))))
+ (base32 "14s97blyqgf9hzxk22iazrghj60midajkw2801dfspz3n2iqmwb3"))))
(build-system cargo-build-system)
(home-page "https://github.com/dtolnay/indoc")
(synopsis "Remove a column of leading whitespace from a string")