summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e7ce71a90f..6fbb3b7c19 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8613,3 +8613,26 @@ and Whitcher (2001); the dual-tree complex wavelet transform (DTCWT) from
Kingsbury (1999, 2001) as implemented by Selesnick; and Hilbert wavelet
pairs (Selesnick 2001, 2002).")
(license license:bsd-3)))
+
+(define-public r-wordcloud
+ (package
+ (name "r-wordcloud")
+ (version "2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "wordcloud" version))
+ (sha256
+ (base32
+ "0j96yyvm6bcrrpbdx4w26piqx44a0vbsr3px9cb4zk8a8da6jwak"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://cran.r-project.org/web/packages/wordcloud")
+ (synopsis "Word clouds")
+ (description
+ "This package provides functionality to create pretty word clouds,
+visualize differences and similarity between documents, and avoid
+over-plotting in scatter plots with text.")
+ (license license:lgpl2.1)))