summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm88
1 files changed, 44 insertions, 44 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 89a581cb5e..3a9a605efe 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -98,14 +98,14 @@ the system clipboards.")
(define-public r-ellipsis
(package
(name "r-ellipsis")
- (version "0.2.0.1")
+ (version "0.3.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "ellipsis" version))
(sha256
(base32
- "0hx9l043433bwm1np9sypph77c7y9dddpz0wrhbkcv01x32jhr8f"))))
+ "01z9gq311nzwv3a0sa49jhm5ylqd59srip4vjkrf23hzgb5i9y0b"))))
(build-system r-build-system)
(propagated-inputs
`(("r-rlang" ,r-rlang)))
@@ -371,14 +371,14 @@ such as copy/paste from an R session.")
(define-public r-callr
(package
(name "r-callr")
- (version "3.3.1")
+ (version "3.3.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "callr" version))
(sha256
(base32
- "0rvrlg86fxr5nadvqa0dr1iifqjs4d1rc32v76m3ccvx6m3xlq5z"))))
+ "12dbqzjngbyaqdyw0yq1blyfx8pagcvx1vqj2jm451hs25nhdrnh"))))
(build-system r-build-system)
(propagated-inputs
`(("r-r6" ,r-r6)
@@ -582,14 +582,14 @@ applications.")
(define-public r-htmltable
(package
(name "r-htmltable")
- (version "1.13.1")
+ (version "1.13.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "htmlTable" version))
(sha256
(base32
- "1l44b33xgj2698k6nz17r8fl0ink14ryzng803apm9d6bnv357v8"))))
+ "0h6jslchlx1dzqqdb70c3n9xlapcym9ykycvr0hc4q3450y8qmvh"))))
(properties `((upstream-name . "htmlTable")))
(build-system r-build-system)
(propagated-inputs
@@ -615,13 +615,13 @@ LaTeX.")
(define-public r-curl
(package
(name "r-curl")
- (version "4.0")
+ (version "4.2")
(source (origin
(method url-fetch)
(uri (cran-uri "curl" version))
(sha256
(base32
- "0wb1j87fa2nd4a9x1w2nmc453nzvx6qiq8dviwc4jr36hsf9ra89"))))
+ "0xh227gvb056wlipjxxbf555z1i1qcs7rr1igvs6k6645y9irrlp"))))
(build-system r-build-system)
(arguments
`(#:phases
@@ -2996,14 +2996,14 @@ provides a one-row summary of model-level statistics.")
(define-public r-recipes
(package
(name "r-recipes")
- (version "0.1.6")
+ (version "0.1.7")
(source
(origin
(method url-fetch)
(uri (cran-uri "recipes" version))
(sha256
(base32
- "1ndz9h0zvdj141r63l8047wbhaj0x8fwzzyq7b8mh78pvrrdpq2i"))))
+ "1gw8x7vqj7k18mfpiqinyfwzv9i5r0pb51k7xcfxsjap6m9nks98"))))
(build-system r-build-system)
(propagated-inputs
`(("r-dplyr" ,r-dplyr)
@@ -4048,14 +4048,14 @@ terminals.")
(define-public r-tinytex
(package
(name "r-tinytex")
- (version "0.15")
+ (version "0.16")
(source
(origin
(method url-fetch)
(uri (cran-uri "tinytex" version))
(sha256
(base32
- "145dmgq7h55mmqqlnnj153j484x2a9s1fbvjbjkdyqzpnz9qh2ax"))))
+ "1dadq9l0527v038b1k1dyfs0dklsgxnmplls3qhqprfgskif8mga"))))
(build-system r-build-system)
(propagated-inputs
`(("r-xfun" ,r-xfun)))
@@ -4166,21 +4166,20 @@ generation, and 2D/3D network visualization.")
(define-public r-ttr
(package
(name "r-ttr")
- (version "0.23-4")
+ (version "0.23-5")
(source
(origin
(method url-fetch)
(uri (cran-uri "TTR" version))
(sha256
(base32
- "18mzyv6cmxmqyqsfwlx2b2k055887mfgc2jgj8xkn8c6m56n05zb"))))
+ "0fxipnyxaz55n4camrk9cs71x9w4dsmjrihysv8i1s6khf825rg6"))))
(properties `((upstream-name . "TTR")))
(build-system r-build-system)
(propagated-inputs
`(("r-curl" ,r-curl)
("r-xts" ,r-xts)
("r-zoo" ,r-zoo)))
- (native-inputs `(("gfortran" ,gfortran)))
(home-page "https://github.com/joshuaulrich/TTR")
(synopsis "Technical trading rules")
(description
@@ -4753,14 +4752,14 @@ files.")
(define-public r-shinyace
(package
(name "r-shinyace")
- (version "0.4.0")
+ (version "0.4.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "shinyAce" version))
(sha256
(base32
- "0hvih5g0pswlnz5rf3blx5yqw11ssxvm8w4klxddp1ap20ncbgl1"))))
+ "1m33dfm2kjirvgix7ybv1kbzgjkicdpv411g9c0q3fw6rnyhfxxn"))))
(properties `((upstream-name . "shinyAce")))
(build-system r-build-system)
(propagated-inputs
@@ -6250,14 +6249,14 @@ vice versa), or to deal with multiple declared missing values.")
(define-public r-sjmisc
(package
(name "r-sjmisc")
- (version "2.8.1")
+ (version "2.8.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "sjmisc" version))
(sha256
(base32
- "1a30n3cyd9h9ilaiai9ywy53f03nikafc47rvpws2c2vghc8mbn7"))))
+ "0rl0bmk91wc4dxdgy008fl0dwkx3ffvys30vgpnr78lb4pk45nb2"))))
(build-system r-build-system)
(propagated-inputs
`(("r-dplyr" ,r-dplyr)
@@ -6265,7 +6264,8 @@ vice versa), or to deal with multiple declared missing values.")
("r-magrittr" ,r-magrittr)
("r-purrr" ,r-purrr)
("r-rlang" ,r-rlang)
- ("r-sjlabelled" ,r-sjlabelled)))
+ ("r-sjlabelled" ,r-sjlabelled)
+ ("r-tidyselect" ,r-tidyselect)))
(home-page "https://github.com/strengejacke/sjmisc")
(synopsis "Data and variable transformation functions")
(description
@@ -7025,14 +7025,14 @@ used to teach mathematics, statistics, computation and modeling.")
(define-public r-raster
(package
(name "r-raster")
- (version "3.0-2")
+ (version "3.0-7")
(source
(origin
(method url-fetch)
(uri (cran-uri "raster" version))
(sha256
(base32
- "0z4qh3ag1iyly4zjvzi3x2namkndkqn3cjb3ac22xd11sq5gdgiz"))))
+ "0faxv71hlxkblvbi3ps1vfzm3wwi0brwzmpsr5114bddcqyiqkvn"))))
(build-system r-build-system)
(propagated-inputs
`(("r-rcpp" ,r-rcpp)
@@ -8215,14 +8215,14 @@ differentiation.")
(define-public r-bayestestr
(package
(name "r-bayestestr")
- (version "0.2.5")
+ (version "0.3.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "bayestestR" version))
(sha256
(base32
- "08d3bsb6li59n17bx1zrqnlnvniyb3vls9kl856km4chx3b2ff82"))))
+ "0r453zb106hj9w53jjgckxqajjf7shlrgv10gjxsv8if6qybdz5b"))))
(properties `((upstream-name . "bayestestR")))
(build-system r-build-system)
(propagated-inputs
@@ -8916,14 +8916,14 @@ address a bug.")
(define-public r-rcppannoy
(package
(name "r-rcppannoy")
- (version "0.0.12")
+ (version "0.0.13")
(source
(origin
(method url-fetch)
(uri (cran-uri "RcppAnnoy" version))
(sha256
(base32
- "1b0fmip9c4i0my1yjrvqy8jxfiiqcggq2kms135q0b53njxnqwwg"))))
+ "1jibp9b07c5ka1kif0nl7f168hxfvysj32wnmnxg85l663hmvm8j"))))
(properties `((upstream-name . "RcppAnnoy")))
(build-system r-build-system)
(propagated-inputs
@@ -8943,14 +8943,14 @@ This package provides an R interface.")
(define-public r-rcpphnsw
(package
(name "r-rcpphnsw")
- (version "0.1.0")
+ (version "0.2.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "RcppHNSW" version))
(sha256
(base32
- "158a069n42pbnjrlmvqsr6bm2cfp9hxpnk3nhp3dwi9qjlq4r9bm"))))
+ "0gqdkw7vkcm544rz45g0hplg836ygzbfwk9gh9wr0817icvdb3qv"))))
(properties `((upstream-name . "RcppHNSW")))
(build-system r-build-system)
(propagated-inputs `(("r-rcpp" ,r-rcpp)))
@@ -9550,14 +9550,14 @@ maps.")
(define-public r-tidytree
(package
(name "r-tidytree")
- (version "0.2.7")
+ (version "0.2.8")
(source
(origin
(method url-fetch)
(uri (cran-uri "tidytree" version))
(sha256
(base32
- "15ky7hj7w08jx94wm0yikckca0apwv3jy5svd77dpzgb2lr9ff9a"))))
+ "1hkddl8kj1g01dy7xiracx81f6b405b3ga2qp4wlrl552b9xxpby"))))
(build-system r-build-system)
(propagated-inputs
`(("r-ape" ,r-ape)
@@ -12772,14 +12772,14 @@ univariate class intervals for mapping or other graphics purposes.")
(define-public r-spdata
(package
(name "r-spdata")
- (version "0.3.0")
+ (version "0.3.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "spData" version))
(sha256
(base32
- "162cqb331ki43jx4r8lpkjpn2l712figd896rnawg9j1jmjyl96y"))))
+ "190msrrpn226x27pcnck4ac34f9k4xcn26cyz2apdri2nzkr6zbw"))))
(properties `((upstream-name . "spData")))
(build-system r-build-system)
(home-page "https://github.com/Nowosad/spData")
@@ -12846,14 +12846,14 @@ tessellation.")
(define-public r-sf
(package
(name "r-sf")
- (version "0.7-7")
+ (version "0.8-0")
(source
(origin
(method url-fetch)
(uri (cran-uri "sf" version))
(sha256
(base32
- "192hw52x1qlif8zyai1kff1wiyr3yl5f7jj1rk3k0nr8das0qy6i"))))
+ "05dyq0vcz2f1fl03hk3v1a4nz4s84yyqw4rc9w9cwfq71gvm9qwf"))))
(build-system r-build-system)
(inputs
`(("gdal" ,gdal)
@@ -12880,14 +12880,14 @@ datum transformations.")
(define-public r-spdep
(package
(name "r-spdep")
- (version "1.1-2")
+ (version "1.1-3")
(source
(origin
(method url-fetch)
(uri (cran-uri "spdep" version))
(sha256
(base32
- "06mk81kc1ml2wjc8wwwgr0wasjcr4mwrxpfa8vfc373bmnha635s"))))
+ "1f8cjffqqc6rnb3n4qym70ca6nz2kvrsd3g587wrqdr79nnbwnrk"))))
(build-system r-build-system)
(propagated-inputs
`(("r-boot" ,r-boot)
@@ -13343,14 +13343,14 @@ authoring books and technical documents with R Markdown.")
(define-public r-optparse
(package
(name "r-optparse")
- (version "1.6.2")
+ (version "1.6.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "optparse" version))
(sha256
(base32
- "0zrp6jakjhawrwfri270ym83vj5a7nvjk0w6b41z41ahw2da99dm"))))
+ "0wyrc42ja3ab5szx46zmz8lm7vzfqxkjca0m0sms8g9hqbmmay6d"))))
(build-system r-build-system)
(propagated-inputs
`(("r-getopt" ,r-getopt)))
@@ -14994,14 +14994,14 @@ in R, including a translation of the original algorithm into R.")
(define-public r-uwot
(package
(name "r-uwot")
- (version "0.1.3")
+ (version "0.1.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "uwot" version))
(sha256
(base32
- "1mq6qi8q9xslh1b99srj480s2a08pfv4bs9m2ykyijj44j9fcdj9"))))
+ "1y9wpzs92d1fl2x5figfywd48lkyhwx37j542z0rf6ckrl46n89n"))))
(build-system r-build-system)
(propagated-inputs
`(("r-dqrng" ,r-dqrng)
@@ -15502,14 +15502,14 @@ in pipelines.")
(define-public r-parameters
(package
(name "r-parameters")
- (version "0.1.0")
+ (version "0.2.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "parameters" version))
(sha256
(base32
- "12v301va1l3xydicbf0k04anxlmyjclbbjfg0riprryhkxwwk8g5"))))
+ "1mgggb3l67wgjiccq4y84wbs2dw9qk01akd553yiwbwky9rpawgh"))))
(properties `((upstream-name . "parameters")))
(build-system r-build-system)
(propagated-inputs
@@ -15614,14 +15614,14 @@ signalled with increasing levels of non-invasive verbosity.")
(define-public r-assertable
(package
(name "r-assertable")
- (version "0.2.6")
+ (version "0.2.7")
(source
(origin
(method url-fetch)
(uri (cran-uri "assertable" version))
(sha256
(base32
- "0jjd6ylh26fykzzv1q2lbajzfj07lyxwb3b3xmr2zdg2fp5b2w4c"))))
+ "1npks9rcrnchmd0silq6qrvqkmdkp9fwjkyyvvp1lqjclyxk6vkk"))))
(build-system r-build-system)
(propagated-inputs
`(("r-data-table" ,r-data-table)))