summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm383
1 files changed, 382 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 749eed8b57..10b191051d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1,10 +1,13 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2017, 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
;;; Copyright © 2018 Sahithi Yarlagadda <sahi@swecha.net>
+;;; Copyright © 2018 Sandeep Subramanian <sandeepsubramanian94@gmail.com>
+;;; Copyright © 2018 Charlie Ritter <chewzeirta@posteo.net>
+;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +38,252 @@
#:use-module (gnu packages statistics)
#:use-module (gnu packages web))
+(define-public r-tidyverse
+ (package
+ (name "r-tidyverse")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidyverse" version))
+ (sha256
+ (base32
+ "0yy3fkjksgcn6wkbgsb0pbnmsyqs4m01mziqafhig578nixs4rxd"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-broom" ,r-broom)
+ ("r-cli" ,r-cli)
+ ("r-crayon" ,r-crayon)
+ ("r-dbplyr" ,r-dbplyr)
+ ("r-dplyr" ,r-dplyr)
+ ("r-forcats" ,r-forcats)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-haven" ,r-haven)
+ ("r-hms" ,r-hms)
+ ("r-httr" ,r-httr)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-lubridate" ,r-lubridate)
+ ("r-magrittr" ,r-magrittr)
+ ("r-modelr" ,r-modelr)
+ ("r-purrr" ,r-purrr)
+ ("r-readr" ,r-readr)
+ ("r-readxl" ,r-readxl)
+ ("r-reprex" ,r-reprex)
+ ("r-rlang" ,r-rlang)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-rvest" ,r-rvest)
+ ("r-stringr" ,r-stringr)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)
+ ("r-xml2" ,r-xml2)))
+ (home-page "https://tidyverse.tidyverse.org")
+ (synopsis "Install and load packages from the \"Tidyverse\"")
+ (description
+ "The @code{tidyverse} is a set of packages that work in harmony because
+they share common data representations and API design. This package is
+designed to make it easy to install and load multiple tidyverse packages in a
+single step.")
+ (license license:gpl3)))
+
+(define-public r-rvest
+ (package
+ (name "r-rvest")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rvest" version))
+ (sha256
+ (base32
+ "04mv99z8dixywx96kfy4215g6ib23s7qvd77hcf9pxqxzcvqhvhd"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-httr" ,r-httr)
+ ("r-magrittr" ,r-magrittr)
+ ("r-selectr" ,r-selectr)
+ ("r-xml2" ,r-xml2)))
+ (home-page "https://github.com/hadley/rvest")
+ (synopsis "Simple web scraping for R")
+ (description
+ "@code{r-rvest} helps you scrape information from web pages. It is
+designed to work with @code{magrittr} to make it easy to express common web
+scraping tasks, inspired by libraries like @code{BeautifulSoup}.")
+ (license license:gpl3)))
+
+(define-public r-selectr
+ (package
+ (name "r-selectr")
+ (version "0.3-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "selectr" version))
+ (sha256
+ (base32
+ "0kdrj64rqg4z6hg92y9r2h602a2i73r5rnlpg23ys33d5d32n8jy"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-stringr" ,r-stringr)))
+ (home-page "https://sjp.co.nz/projects/selectr/")
+ (synopsis "Translate CSS selectors to XPath expressions")
+ (description
+ "@code{r-selectr} translates a CSS3 selector into an equivalent XPath
+expression. This allows you to use CSS selectors when working with the XML
+package as it can only evaluate XPath expressions. Also provided are
+convenience functions useful for using CSS selectors on XML nodes. This
+package is a port of the Python package @code{cssselect}.")
+ (license license:bsd-3)))
+
+(define-public r-reprex
+ (package
+ (name "r-reprex")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "reprex" version))
+ (sha256
+ (base32
+ "105d9vsmqfilgpw8psfb2wyiz1hvcycvh4cqhb3ab37lm3rcavvs"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-callr" ,r-callr)
+ ("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-whisker" ,r-whisker)))
+ (home-page "https://github.com/tidyverse/reprex")
+ (synopsis "Prepare reproducible R code examples for sharing")
+ (description
+ "This package provides a convenience wrapper that uses the
+@code{rmarkdown} package to render small snippets of code to target formats
+that include both code and output. The goal is to encourage the sharing of
+small, reproducible, and runnable examples on code-oriented websites or email.
+@code{reprex} also extracts clean, runnable R code from various common formats,
+such as copy/paste from an R session.")
+ (license license:expat)))
+
+(define-public r-callr
+ (package
+ (name "r-callr")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "callr" version))
+ (sha256
+ (base32
+ "0m51p39vfwldxv6h8x4y9w3laf8q9bldhfqhlcrlx3xhy3irb1bp"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-crayon" ,r-crayon)
+ ("r-debugme" ,r-debugme)
+ ("r-r6" ,r-r6)
+ ("r-testthat" ,r-testthat)))
+ (home-page "https://github.com/r-lib/callr#readme")
+ (synopsis "Call R from R")
+ (description
+ "It is sometimes useful to perform a computation in a separate R process,
+without affecting the current R process at all. This packages does exactly
+that.")
+ (license license:expat)))
+
+(define-public r-readxl
+ (package
+ (name "r-readxl")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "readxl" version))
+ (sha256
+ (base32
+ "1bf7gxw9r11m4llyymplxiaa4gzgyj4bwmwad5in756pzq3jzmpv"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cellranger" ,r-cellranger)
+ ("r-rcpp" ,r-rcpp)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://readxl.tidyverse.org")
+ (synopsis "Read Excel files")
+ (description
+ "This package lets you import Excel files into R. It supports
+@file{.xls} via the embedded @code{libxls} C library and @file{.xlsx} via
+the embedded @code{RapidXML} C++ library.")
+ ;; XXX: This package bundles a copy of 'libxsl' which is BSD-2 and
+ ;; 'rapidxml' which is Boost.
+ (license (list license:gpl3 license:bsd-2 license:boost1.0))))
+
+(define-public r-modelr
+ (package
+ (name "r-modelr")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "modelr" version))
+ (sha256
+ (base32
+ "1rqw0b583vp107zqp4h3wj51dvv4hb3wszfr1f5f48xassc53f95"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-broom" ,r-broom)
+ ("r-dplyr" ,r-dplyr)
+ ("r-lazyeval" ,r-lazyeval)
+ ("r-magrittr" ,r-magrittr)
+ ("r-purrr" ,r-purrr)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)))
+ (home-page "https://github.com/tidyverse/modelr")
+ (synopsis "Helper functions for modelling in pipelines")
+ (description
+ "Functions for modelling that help you seamlessly integrate modelling
+into a pipeline of data manipulation and visualisation.")
+ (license license:gpl3)))
+
+(define-public r-haven
+ (package
+ (name "r-haven")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "haven" version))
+ (sha256
+ (base32
+ "1fkcvsrnw8waqwggv0aydbvbi99x5kp9g78xfxj4w6s3xvdzcysz"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-forcats" ,r-forcats)
+ ("r-hms" ,r-hms)
+ ("r-rcpp" ,r-rcpp)
+ ("r-readr" ,r-readr)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://haven.tidyverse.org")
+ (synopsis "Import and Export 'SPSS', 'Stata' and 'SAS' Files")
+ (description
+ "This package lets you mport foreign statistical formats into R via the
+embedded @url{https://github.com/WizardMac/ReadStat,ReadStat} C library.")
+ (license license:expat)))
+
+(define-public r-amap
+ (package
+ (name "r-amap")
+ (version "0.8-14")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "amap" version))
+ (sha256
+ (base32
+ "1dz37z9v4zvyvqrs4xvpfv468jwvpxav60qn2w0049bw8llj6xdl"))))
+ (build-system r-build-system)
+ (inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "http://mulcyber.toulouse.inra.fr/projects/amap/")
+ (synopsis "Another multidimensional analysis package")
+ (description "This package provides tools for clustering and principal
+component analysis (with robust methods, and parallelized functions).")
+ (license license:gpl2+)))
+
(define-public r-ape
(package
(name "r-ape")
@@ -131,6 +380,27 @@ inspired by Python's Literal String Interpolation (PEP-0498) and
Docstrings (PEP-0257) and Julia's Triple-Quoted String Literals.")
(license license:expat)))
+(define-public r-pastecs
+ (package
+ (name "r-pastecs")
+ (version "1.3.21")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "pastecs" version))
+ (sha256
+ (base32
+ "0z4dic94ar646w7zc2ggi5hgvf2qnznsani94c5pyql8zspz47lc"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-boot" ,r-boot)))
+ (home-page "http://www.sciviews.org/pastecs")
+ (synopsis "Analysis of space-time ecological series")
+ (description
+ "This package provides functions for regulation, decomposition and analysis
+of space-time series. The @code{pastecs} library is a PNEC-Art4 and IFREMER
+initiative to bring PASSTEC 2000 functionalities to R.")
+ (license license:gpl2+)))
+
(define-public r-plogr
(package
(name "r-plogr")
@@ -779,6 +1049,26 @@ tools for inference in parametric models are provided.")
;; Either version is okay
(license (list license:gpl2 license:gpl3))))
+(define-public r-idr
+ (package
+ (name "r-idr")
+ (version "1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "idr" version))
+ (sha256
+ (base32
+ "05nvgw1xdg670bsjjrxkgd1mrdkciccpw4krn0zcgdf2r21dzgwb"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/idr/")
+ (synopsis "Irreproducible discovery rate")
+ (description
+ "This is a package for estimating the copula mixture model and plotting
+correspondence curves in \"Measuring reproducibility of high-throughput
+experiments\" (2011), Annals of Applied Statistics, Vol. 5, No. 3, 1752-1779,
+by Li, Brown, Huang, and Bickel")
+ (license license:gpl2+)))
+
(define-public r-inline
(package
(name "r-inline")
@@ -1625,6 +1915,29 @@ University Press. It provides smoothing methods for nonparametric regression
and density estimation")
(license license:gpl2+)))
+(define-public r-venndiagram
+ (package
+ (name "r-venndiagram")
+ (version "1.6.20")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "VennDiagram" version))
+ (sha256
+ (base32
+ "1ic1jaxzw98si2p4n1fl4n3myhd7fpw0njb634cwhviwybzv6775"))))
+ (properties `((upstream-name . "VennDiagram")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-futile-logger" ,r-futile-logger)))
+ (home-page "https://cran.r-project.org/web/packages/VennDiagram/")
+ (synopsis "Generate High-Resolution Venn and Euler Plots")
+ (description
+ "This package provides a set of functions to generate high-resolution
+Venn and Euler plots. It includes handling for several special cases,
+including two-case scaling, and extensive customization of plot shape and
+structure.")
+ (license license:gpl2+)))
+
(define-public r-vioplot
(package
(name "r-vioplot")
@@ -3273,3 +3586,71 @@ those functions to be used with time series including specifications that may
contain lags, diffs and missing values.")
;; Any GPL version.
(license license:gpl2+)))
+
+(define-public r-catdap
+ (package
+ (name "r-catdap")
+ (version "1.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "catdap" version))
+ (sha256
+ (base32
+ "0i877l61f6c75pczi235rzci67w29zv1d7z5zn5p5ymndclvlpl2"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/catdap/")
+ (synopsis "Tools for categorical data analysis")
+ (description
+ "This package provides functions for analyzing multivariate data.
+Dependencies of the distribution of the specified variable (response
+variable) to other variables (explanatory variables) are derived and
+evaluated by the @dfn{Akaike Information Criterion} (AIC).")
+ (license license:gpl2+)))
+
+(define-public r-arules
+ (package
+ (name "r-arules")
+ (version "1.6-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "arules" version))
+ (sha256
+ (base32
+ "14gbq5k2zkx4wc7kkfazz313ngij89qp1xmyxfg3nq3v1s84c3sl"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrix" ,r-matrix)))
+ (home-page "https://github.com/mhahsler/arules")
+ (synopsis "Mining association rules and frequent itemsets")
+ (description
+ "This package provides an infrastructure for representing, manipulating
+and analyzing transaction data and patterns (frequent itemsets and association rules).
+It also provides C implementations of the association mining algorithms Apriori
+and Eclat.")
+ (license license:gpl3)))
+
+(define-public r-parsedate
+ (package
+ (name "r-parsedate")
+ (version "1.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "parsedate" version))
+ (sha256
+ (base32
+ "0mg7hbm3903iwvmpn51gjpaaq03rsp72hjb1g8h5g84r81iha002"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/gaborcsardi/parsedate")
+ (synopsis
+ "Recognize and parse dates in various formats")
+ (description
+ "This package provides three functions for dealing with dates:
+@code{parse_iso_8601} recognizes and parses all valid ISO 8601 date and
+time formats, @code{parse_date} parses dates in unspecified formats,
+and @code{format_iso_8601} formats a date in ISO 8601 format.")
+ (license license:gpl2)))