summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm69
1 files changed, 40 insertions, 29 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4ef2f922ec..406ccc644b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4066,20 +4066,22 @@ to variables on the left-hand side of the assignment.")
(define-public r-vctrs
(package
(name "r-vctrs")
- (version "0.2.3")
+ (version "0.2.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "vctrs" version))
(sha256
(base32
- "1pnjnxp1pwsr083qa6xp5akls6q0pnjz8pq2m9d7z3kc1886sw8w"))))
+ "15sgzs6afvmhssk6jcg41rn3bvmzmbm4sgca6f6x8lfrsazvdj6w"))))
(build-system r-build-system)
(propagated-inputs
`(("r-digest" ,r-digest)
("r-ellipsis" ,r-ellipsis)
("r-glue" ,r-glue)
("r-rlang" ,r-rlang)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/r-lib/vctrs")
(synopsis "Vector helpers")
(description
@@ -5168,14 +5170,14 @@ specific S3-method.")
(define-public r-vim
(package
(name "r-vim")
- (version "5.1.0")
+ (version "5.1.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "VIM" version))
(sha256
(base32
- "09600piny3qrxrmh8844iwrvgrhwan1c3nlh6irqy1vjha2w4gb3"))))
+ "0w22ir0gvym7gqd6nw2j7w5ivlb3az1dkfxv33imimkb7c83056a"))))
(properties `((upstream-name . "VIM")))
(build-system r-build-system)
(propagated-inputs
@@ -5303,14 +5305,14 @@ contain lags, diffs and missing values.")
(define-public r-catdap
(package
(name "r-catdap")
- (version "1.3.4")
+ (version "1.3.5")
(source
(origin
(method url-fetch)
(uri (cran-uri "catdap" version))
(sha256
(base32
- "0i877l61f6c75pczi235rzci67w29zv1d7z5zn5p5ymndclvlpl2"))))
+ "0fyhl69z2lznymvpzxra9qvcg85ggzkfjy68c6mzdmf1ja44d2k5"))))
(build-system r-build-system)
(native-inputs
`(("gfortran" ,gfortran)))
@@ -8585,20 +8587,19 @@ conversion of indices such as Cohen's d, r, odds, etc.")
(define-public r-sjplot
(package
(name "r-sjplot")
- (version "2.8.2")
+ (version "2.8.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "sjPlot" version))
(sha256
- (base32 "16721a5006q0gv45zjcwnkykxhjkzpq5n35vhik0g0ixgm3a2vci"))))
+ (base32 "0ip1rkjlhyf3axlc8qqss1qq1f0xrda890c1jmcbhm98wwjw264f"))))
(properties `((upstream-name . "sjPlot")))
(build-system r-build-system)
(propagated-inputs
`(("r-bayestestr" ,r-bayestestr)
("r-dplyr" ,r-dplyr)
("r-effectsize" ,r-effectsize)
- ("r-forcats" ,r-forcats)
("r-ggeffects" ,r-ggeffects)
("r-ggplot2" ,r-ggplot2)
("r-insight" ,r-insight)
@@ -8613,6 +8614,8 @@ conversion of indices such as Cohen's d, r, odds, etc.")
("r-sjmisc" ,r-sjmisc)
("r-sjstats" ,r-sjstats)
("r-tidyr" ,r-tidyr)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://strengejacke.github.io/sjPlot/")
(synopsis "Data visualization for statistics in social science")
(description
@@ -9240,14 +9243,14 @@ package provides a minimal R interface by relying on the Rcpp package.")
(define-public r-rcppparallel
(package
(name "r-rcppparallel")
- (version "4.4.4")
+ (version "5.0.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "RcppParallel" version))
(sha256
(base32
- "0p13f2mywjr7gmskf8ri4y8p5yr1bvr4xrpw2w11vdvafwz1vcia"))))
+ "1mhd6vp47xmfw533h0pkvydv96m57fspvd85g8m7iqb5rcxvhhdb"))))
(properties `((upstream-name . "RcppParallel")))
(build-system r-build-system)
(home-page "http://rcppcore.github.io/RcppParallel")
@@ -9823,13 +9826,13 @@ maps.")
(define-public r-tidytree
(package
(name "r-tidytree")
- (version "0.3.1")
+ (version "0.3.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "tidytree" version))
(sha256
- (base32 "1bnzs62z2l8ck2h9gabmxvayizv4nfn8dmyzry83fv0cspjbyiv7"))))
+ (base32 "0dx9jn19mfykn20camsmq1amlgg0w6z5hn5rdqygs1fk1l5aazad"))))
(build-system r-build-system)
(propagated-inputs
`(("r-ape" ,r-ape)
@@ -9838,6 +9841,8 @@ maps.")
("r-magrittr" ,r-magrittr)
("r-rlang" ,r-rlang)
("r-tibble" ,r-tibble)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/GuangchuangYu/tidytree")
(synopsis "Tidy tool for phylogenetic tree data manipulation")
(description
@@ -11200,14 +11205,14 @@ covariance functions for large data sets.")
(define-public r-spatialextremes
(package
(name "r-spatialextremes")
- (version "2.0-7.2")
+ (version "2.0-8")
(source
(origin
(method url-fetch)
(uri (cran-uri "SpatialExtremes" version))
(sha256
(base32
- "0aqq9ryxi4xsdqjhc1lhb7ai8szs7m2vys6nn0ygps1w3pm4xwj8"))))
+ "0r2byz5xxc46zqnigdax28q7446ibmzmsmi10lmm2hdks3ml6sl3"))))
(properties
`((upstream-name . "SpatialExtremes")))
(build-system r-build-system)
@@ -13245,13 +13250,13 @@ also provided to illustrate various methods.")
(define-public r-pegas
(package
(name "r-pegas")
- (version "0.12")
+ (version "0.13")
(source
(origin
(method url-fetch)
(uri (cran-uri "pegas" version))
(sha256
- (base32 "0sb8cmz4d238mcb56hv9fa0cagm00k82r7aj4cj4lxa1flxlpy8p"))))
+ (base32 "002i7s4g0nhnq0v05gs0yssqiyhpq2f7rw2rhn31hsbgxc86frvy"))))
(build-system r-build-system)
(propagated-inputs
`(("r-adegenet" ,r-adegenet)
@@ -14077,19 +14082,21 @@ package.")
(define-public r-ggplotify
(package
(name "r-ggplotify")
- (version "0.0.4")
+ (version "0.0.5")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggplotify" version))
(sha256
(base32
- "0nv3wdmxnc5ww9m3xlgnb0jp30j45dg33nqc6gg3y36svg8anjcg"))))
+ "0pfnp4lrissf21z7867kdm6slr979kchyva8iaf83i1302kscph3"))))
(build-system r-build-system)
(propagated-inputs
`(("r-ggplot2" ,r-ggplot2)
("r-gridgraphics" ,r-gridgraphics)
("r-rvcheck" ,r-rvcheck)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/GuangchuangYu/ggplotify")
(synopsis "Convert plots to @code{grob} or @code{ggplot} object")
(description
@@ -15212,14 +15219,14 @@ includes data sets from oceanography.")
(define-public r-ggfortify
(package
(name "r-ggfortify")
- (version "0.4.8")
+ (version "0.4.9")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggfortify" version))
(sha256
(base32
- "191q2z7w0l4v7swjlxs2hjgbjngw2838688s7ygnj0kigsm310f3"))))
+ "1p6knrbyaynaqwd939w09hpf1zz1gn95cb46sfgppl8l98krb2h5"))))
(build-system r-build-system)
(propagated-inputs
`(("r-dplyr" ,r-dplyr)
@@ -15229,6 +15236,8 @@ includes data sets from oceanography.")
("r-stringr" ,r-stringr)
("r-tibble" ,r-tibble)
("r-tidyr" ,r-tidyr)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/sinhrks/ggfortify")
(synopsis "Data visualization tools for statistical analysis results")
(description
@@ -15754,14 +15763,14 @@ be used further by e.g. graphic devices.")
(define-public r-graphlayouts
(package
(name "r-graphlayouts")
- (version "0.5.0")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "graphlayouts" version))
(sha256
(base32
- "03dizbhhdhnzbj2i5zvqgs617kwcv4h2pha4f16adic0fph1rxl3"))))
+ "1la016m37kp79zk8p1yx9kaha8y6d4w52w39h0mzv1mfsi6d75w0"))))
(properties `((upstream-name . "graphlayouts")))
(build-system r-build-system)
(propagated-inputs
@@ -15871,19 +15880,21 @@ in pipelines.")
(define-public r-parameters
(package
(name "r-parameters")
- (version "0.5.0")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "parameters" version))
(sha256
(base32
- "19cblrq079svp5j3wgikw5fsdbsp1w0f2llm7kcf1rg5w1aagjr7"))))
+ "0zin3ikc013hc713n5zs0dbhc3m4nfw1vhc3924z0mrww8r241xn"))))
(properties `((upstream-name . "parameters")))
(build-system r-build-system)
(propagated-inputs
`(("r-bayestestr" ,r-bayestestr)
("r-insight" ,r-insight)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://cran.r-project.org/web/packages/parameters")
(synopsis "Processing of model parameters")
(description
@@ -20086,14 +20097,14 @@ translated to input syntax for the R packages @code{sem} and @code{lavaan}.")
(define-public r-cdm
(package
(name "r-cdm")
- (version "7.4-19")
+ (version "7.5-15")
(source
(origin
(method url-fetch)
(uri (cran-uri "CDM" version))
(sha256
(base32
- "1ln1r3rk004fmk55iy08bjh3vv4wnkb8zg2wj3r9rq7pi8jn8fv4"))))
+ "159ny2dz0rf1r3k1mqlfwambffc8rx425sggf5bn51nybpzanq3l"))))
(properties `((upstream-name . "CDM")))
(build-system r-build-system)
(propagated-inputs
@@ -20120,14 +20131,14 @@ well as Ravand and Robitzsch (2015).")
(define-public r-tam
(package
(name "r-tam")
- (version "3.3-10")
+ (version "3.4-26")
(source
(origin
(method url-fetch)
(uri (cran-uri "TAM" version))
(sha256
(base32
- "1rkjp5x6wrk1dfspp1imvfals0wvy4w1wb8a5mhfbnilc7vgnlbq"))))
+ "111d7qkxhwh1lfvldyh9d61pdb5vb6x8lr8n9h95ssvw07vjqvk9"))))
(properties `((upstream-name . "TAM")))
(build-system r-build-system)
(propagated-inputs