summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm343
1 files changed, 309 insertions, 34 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 040c2ead4a..8277026c32 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016, 2017, 2018 Roel Janssen <roel@gnu.org>
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Eric Brown <brown@fastmail.com>
-;;; Copyright © 2018, 2019 Brett Gilio <brettg@posteo.net>
+;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;;
@@ -62,6 +62,7 @@
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages java)
#:use-module (gnu packages javascript)
+ #:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages machine-learning)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
@@ -2361,21 +2362,44 @@ and S4 methods with inlined C, C++ or Fortran code supporting @code{.C} and
;; Any version of the LGPL.
(license license:lgpl3+)))
+(define-public r-bdsmatrix
+ (package
+ (name "r-bdsmatrix")
+ (version "1.3-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "bdsmatrix" version))
+ (sha256
+ (base32
+ "17ddvz4gnih7rx0lr1gzk280xyh6x796cf2x794dvplpiiq83skh"))))
+ (properties `((upstream-name . "bdsmatrix")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/bdsmatrix/")
+ (synopsis "Routines for block diagonal symmetric matrices")
+ (description
+ "This package provides procedures to work with block diagonal symmetric
+matrices, a special case of sparse matrices.")
+ (license license:lgpl2.0)))
+
(define-public r-bbmle
(package
(name "r-bbmle")
- (version "1.0.20")
+ (version "1.0.22")
(source
(origin
(method url-fetch)
(uri (cran-uri "bbmle" version))
(sha256
(base32
- "1xzij7swrrzl5ly8l3lw6awh486zcm00251dwqws1y23fbgyh3vc"))))
+ "1idn55w5f3iw4r0ydyww8xyinninw07sxlwfqb565vmdrs87dwl4"))))
(build-system r-build-system)
(propagated-inputs
- `(("r-lattice" ,r-lattice)
+ `(("r-bdsmatrix" ,r-bdsmatrix)
+ ("r-lattice" ,r-lattice)
("r-mass" ,r-mass)
+ ("r-matrix" ,r-matrix)
+ ("r-mvtnorm" ,r-mvtnorm)
("r-numderiv" ,r-numderiv)))
(home-page "https://cran.r-project.org/web/packages/bbmle")
(synopsis "Tools for General Maximum Likelihood Estimation")
@@ -2991,14 +3015,14 @@ problems as well as resampling based estimators of prediction error.")
(define-public r-psych
(package
(name "r-psych")
- (version "1.8.12")
+ (version "1.9.12")
(source
(origin
(method url-fetch)
(uri (cran-uri "psych" version))
(sha256
(base32
- "0hvp0dkkkn0szaf5rkirr3kb8qmr4bxwl775m5wmpvn1kc25w5vf"))))
+ "13r7fyjsl93m121awnwfhya8a0lw0l2byn60yqdbf9gp3lmb9ny0"))))
(build-system r-build-system)
(propagated-inputs
`(("r-foreign" ,r-foreign)
@@ -3080,14 +3104,14 @@ provides a one-row summary of model-level statistics.")
(define-public r-recipes
(package
(name "r-recipes")
- (version "0.1.7")
+ (version "0.1.8")
(source
(origin
(method url-fetch)
(uri (cran-uri "recipes" version))
(sha256
(base32
- "1gw8x7vqj7k18mfpiqinyfwzv9i5r0pb51k7xcfxsjap6m9nks98"))))
+ "1n32qc2a3n9cykm8dv9qcr77kdhqfsjiqf6kgfk9s0lnpx2zaldm"))))
(build-system r-build-system)
(propagated-inputs
`(("r-dplyr" ,r-dplyr)
@@ -4047,14 +4071,14 @@ to variables on the left-hand side of the assignment.")
(define-public r-vctrs
(package
(name "r-vctrs")
- (version "0.2.0")
+ (version "0.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "vctrs" version))
(sha256
(base32
- "05h0y8qzwc899qj84gkhg4jwzscd065as00d4d8smv42h4i8zkjv"))))
+ "0rlwjfvvhv3s5mj4lqhwlqwddpizyp46i1qbcvw0mzb5q8b0nkz0"))))
(build-system r-build-system)
(propagated-inputs
`(("r-backports" ,r-backports)
@@ -4086,14 +4110,14 @@ to variables on the left-hand side of the assignment.")
(define-public r-pillar
(package
(name "r-pillar")
- (version "1.4.2")
+ (version "1.4.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "pillar" version))
(sha256
(base32
- "0988047mf0xdhdkqqmavzx4ifjhndjnxniyrrhrdq1nvnrvbpfms"))))
+ "02sn7zw80wq33jgxk2i6m5jb83sk7y72dfhgyy0apfinv05w92ss"))))
(build-system r-build-system)
(propagated-inputs
`(("r-cli" ,r-cli)
@@ -5721,18 +5745,19 @@ obtain a better initial configuration in non-metric MDS.")
(define-public r-reticulate
(package
(name "r-reticulate")
- (version "1.13")
+ (version "1.14")
(source
(origin
(method url-fetch)
(uri (cran-uri "reticulate" version))
(sha256
(base32
- "1qwxh7zq9igl7dxl5g5qjbvv0mlac3w80djnkm0w8rxnaval3gmd"))))
+ "0icb9zl9zlx75njv7y1dr450k0yw2n3q2jkr4nicnphdyfn69gkn"))))
(build-system r-build-system)
(inputs `(("python" ,python)))
(propagated-inputs
- `(("r-jsonlite" ,r-jsonlite)
+ `(("r-rappdirs" ,r-rappdirs)
+ ("r-jsonlite" ,r-jsonlite)
("r-matrix" ,r-matrix)
("r-rcpp" ,r-rcpp)))
(home-page "https://github.com/rstudio/reticulate")
@@ -5747,14 +5772,14 @@ Python to R they are converted back to R types.")
(define-public r-bibtex
(package
(name "r-bibtex")
- (version "0.4.2")
+ (version "0.4.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "bibtex" version))
(sha256
(base32
- "0wl3925ryd54g1nv3ncwllc493d39dpgy5md61940h69c0van1hz"))))
+ "1ks1w59ldwmfd1sj8ap7smyhf8dhykv7xnwrl8z9xzkcfpv1rbc0"))))
(build-system r-build-system)
(propagated-inputs `(("r-stringr" ,r-stringr)))
(home-page "https://github.com/romainfrancois/bibtex")
@@ -6871,14 +6896,14 @@ bootstrap. Confidence intervals can be computed for (p)AUC or ROC curves.")
(define-public r-rootsolve
(package
(name "r-rootsolve")
- (version "1.8.1")
+ (version "1.8.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "rootSolve" version))
(sha256
(base32
- "0skrspq7sd7gaq73w91km14v8znc8chncgy64hvjgcng2xw15phx"))))
+ "0rj7c4zcrzgz7sb0vgvh7swpfafnw4040cxp7ypas3s8fnihn54l"))))
(properties `((upstream-name . "rootSolve")))
(build-system r-build-system)
(native-inputs `(("gfortran" ,gfortran)))
@@ -6929,13 +6954,13 @@ the analyzed items.")
(define-public r-slam
(package
(name "r-slam")
- (version "0.1-46")
+ (version "0.1-47")
(source
(origin
(method url-fetch)
(uri (cran-uri "slam" version))
(sha256
- (base32 "1ihhbx76miwys35gsbhijriadvrw4f51lc3v45pnn6cvcfd9hr0b"))))
+ (base32 "12fggw2c7hz3bpvsaqm24g3r6lbpq6jgli24g7x5j859iak5cqv9"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/slam/")
(synopsis "Sparse lightweight arrays and matrices")
@@ -12550,6 +12575,12 @@ running IRkernel session.")
"--name" "ir"
"--prefix" out
(string-append out "/site-library/IRkernel/kernelspec"))
+ ;; Record the absolute file name of the 'R' executable in
+ ;; 'kernel.json'.
+ (substitute* (string-append out "/share/jupyter"
+ "/kernels/ir/kernel.json")
+ (("\\[\"R\",")
+ (string-append "[\"" (which "R") "\",")))
#t))))))
(inputs
`(("jupyter" ,jupyter)))
@@ -12559,6 +12590,8 @@ running IRkernel session.")
("r-evaluate" ,r-evaluate)
("r-irdisplay" ,r-irdisplay)
("r-jsonlite" ,r-jsonlite)
+ ;; sets R_LIBS_SITE, so R can actually find this package (IRkernel)
+ ("r-minimal" ,r-minimal)
("r-pbdzmq" ,r-pbdzmq)
("r-repr" ,r-repr)
("r-uuid" ,r-uuid)))
@@ -14885,18 +14918,17 @@ code edited with @code{RStudio IDE}, @code{Emacs} and @code{Vim}.")
(define-public r-sctransform
(package
(name "r-sctransform")
- (version "0.2.0")
+ (version "0.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "sctransform" version))
(sha256
(base32
- "1r5kiqqs318q59h2i8m7c6nhghp9w6q26ss2y5a390lkhsawgx6p"))))
+ "07v3lzccsrkh1glfxd1q20r8f8gl9ls5az0s1dvxm4vcls0hlhyn"))))
(build-system r-build-system)
(propagated-inputs
- `(("r-future" ,r-future)
- ("r-future-apply" ,r-future-apply)
+ `(("r-future-apply" ,r-future-apply)
("r-ggplot2" ,r-ggplot2)
("r-gridextra" ,r-gridextra)
("r-mass" ,r-mass)
@@ -15172,14 +15204,14 @@ annotated biological functions.")
(define-public r-plot3d
(package
(name "r-plot3d")
- (version "1.1.1")
+ (version "1.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "plot3D" version))
(sha256
(base32
- "0chn70fqwyca8lbnjnpbcj08ni0dfbax2gjmzhk2c4w72c04mzpn"))))
+ "1jfzndnlci9a975qbcv66jiy2l46hs3f2049654x4jp3i4kyrr5r"))))
(properties `((upstream-name . "plot3D")))
(build-system r-build-system)
(propagated-inputs `(("r-misc3d" ,r-misc3d)))
@@ -15904,19 +15936,18 @@ PROJ.4 library.")
(define-public r-insol
(package
(name "r-insol")
- (version "1.2")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "insol" version))
(sha256
(base32
- "14ikz05375pjn9hby7kwkhcnykjilbnkdy5i8lsl7c5qdbhmqcm5"))))
+ "1d2vqmbp94ff80mfkmq4a8y12r6ryym8hh1568ip9qbn7snc64v1"))))
(properties `((upstream-name . "insol")))
(build-system r-build-system)
(propagated-inputs
- `(("r-raster" ,r-raster)
- ("r-rgdal" ,r-rgdal)))
+ `(("r-raster" ,r-raster)))
(native-inputs
`(("gfortran" ,gfortran)))
(home-page "https://meteoexploration.com/R/insol/index.html")
@@ -16007,13 +16038,13 @@ programming problems.")
(define-public r-desolve
(package
(name "r-desolve")
- (version "1.25")
+ (version "1.27")
(source
(origin
(method url-fetch)
(uri (cran-uri "deSolve" version))
(sha256
- (base32 "0735y3p5glhqx69rzrc8qgmvs7p7w0p98qxmvylb6bgqp6kp0cbp"))))
+ (base32 "1qhjq4vxlxd9qmhf6i26x1k7bzhldlxzbby1zgcplicdvlqk951d"))))
(properties `((upstream-name . "deSolve")))
(build-system r-build-system)
(native-inputs
@@ -18966,3 +18997,247 @@ algorithm to identify key players, and Valente's bridging metric. The
betweenness, Key Players, and bridging implementations are parallelized with
OpenMP.")
(license license:gpl2)))
+
+(define-public r-emplik
+ (package
+ (name "r-emplik")
+ (version "1.0-4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "emplik" version))
+ (sha256
+ (base32
+ "1g4hz85bvw29c77zs0ig487z92jjl682vv457x81l077h0psvk7c"))))
+ (properties `((upstream-name . "emplik")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-quantreg" ,r-quantreg)))
+ (home-page "http://www.ms.uky.edu/~mai/EmpLik.html")
+ (synopsis "Empirical likelihood ratio for censored/truncated data")
+ (description
+ "This package provides empirical likelihood ratio tests for
+means/quantiles/hazards from possibly censored and/or truncated data. It also
+does regression.")
+ (license license:gpl2+)))
+
+(define-public r-imputeyn
+ (package
+ (name "r-imputeyn")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "imputeYn" version))
+ (sha256
+ (base32
+ "1b21w1aa5f7yiq8k0wa86wvbg4ij7f6ldwn6asfqwb0b90rvsgvs"))))
+ (properties `((upstream-name . "imputeYn")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-boot" ,r-boot)
+ ("r-emplik" ,r-emplik)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-quadprog" ,r-quadprog)
+ ("r-survival" ,r-survival)))
+ (home-page "https://cran.r-project.org/web/packages/imputeYn/")
+ (synopsis "Impute last largest censored observation under weighted least squares")
+ (description
+ "This package allows for the imputation of the last largest censored
+observantions. This method brings less bias and more efficient estimates for
+AFT models.")
+ (license license:gpl2)))
+
+(define-public r-adapenetclass
+ (package
+ (name "r-adapenetclass")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "AdapEnetClass" version))
+ (sha256
+ (base32
+ "01k3mj4g1ckbng7wkzzn9h0k9yf01cpnnkly0sjda574c5jhj0rc"))))
+ (properties `((upstream-name . "AdapEnetClass")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-glmnet" ,r-glmnet)
+ ("r-imputeyn" ,r-imputeyn)
+ ("r-lars" ,r-lars)
+ ("r-quadprog" ,r-quadprog)))
+ (home-page "https://cran.r-project.org/web/packages/AdapEnetClass/")
+ (synopsis "Class of adaptive elastic net methods for censored data")
+ (description
+ "This package provides methods for variable selection for AFT models.")
+ (license license:gpl2)))
+
+(define-public r-flock
+ (package
+ (name "r-flock")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "flock" version))
+ (sha256
+ (base32
+ "1zg93p74icj4bhxnmnssj2xp6vw4yaksyavq03497v33xfpdxss7"))))
+ (properties `((upstream-name . "flock")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+ (home-page "https://cran.r-project.org/web/packages/flock/")
+ (synopsis "Process synchronization using file locks")
+ (description
+ "This package implements synchronization between R processes (spawned by
+using the @code{parallel} package for instance) using file locks. It supports
+both exclusive and shared locking.")
+ (license license:asl2.0)))
+
+(define-public r-archivist
+ (package
+ (name "r-archivist")
+ (version "2.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "archivist" version))
+ (sha256
+ (base32
+ "1i11hrcq1910jgd6diw6h3sxx624v57zjianm49pqvb2dvd0b8y7"))))
+ (properties `((upstream-name . "archivist")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dbi" ,r-dbi)
+ ("r-digest" ,r-digest)
+ ("r-flock" ,r-flock)
+ ("r-httr" ,r-httr)
+ ("r-lubridate" ,r-lubridate)
+ ("r-magrittr" ,r-magrittr)
+ ("r-rcurl" ,r-rcurl)
+ ("r-rsqlite" ,r-rsqlite)))
+ (home-page "https://pbiecek.github.io/archivist/")
+ (synopsis "Tools for storing, restoring and searching for R objects")
+ (description
+ "Data exploration and modelling is a process in which a lot of data
+artifacts are produced. Artifacts like: subsets, data aggregates, plots,
+statistical models, different versions of data sets and different versions of
+results. Archivist helps to store and manage artifacts created in R. It
+allows you to store selected artifacts as binary files together with their
+metadata and relations. Archivist allows sharing artifacts with others. It
+can look for already created artifacts by using its class, name, date of the
+creation or other properties. It also makes it easy to restore such
+artifacts.")
+ (license license:gpl2)))
+
+(define-public r-versions
+ (package
+ (name "r-versions")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "versions" version))
+ (sha256
+ (base32
+ "0zm49j785dgv7fyr1yl9q5f0dsk8hhpim5q5bpkgrkzv7pwjribd"))))
+ (properties `((upstream-name . "versions")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/versions/")
+ (synopsis "Query and install specific versions of CRAN packages")
+ (description
+ "This package allows you to install specified versions of R packages
+hosted on CRAN and provides functions to list available versions and the
+versions of currently installed packages.")
+ (license license:bsd-3)))
+
+(define-public r-adapr
+ (package
+ (name "r-adapr")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "adapr" version))
+ (sha256
+ (base32
+ "1s57jdbi5pik56xjz1d4438ax6cywg2yq2s47h5g6wrwvpgr1qfw"))))
+ (properties `((upstream-name . "adapr")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-archivist" ,r-archivist)
+ ("r-devtools" ,r-devtools)
+ ("r-digest" ,r-digest)
+ ("r-doparallel" ,r-doparallel)
+ ("r-gdata" ,r-gdata)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-git2r" ,r-git2r)
+ ("r-igraph" ,r-igraph)
+ ("r-knitr" ,r-knitr)
+ ("r-plotly" ,r-plotly)
+ ("r-plyr" ,r-plyr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-shiny" ,r-shiny)
+ ("r-shinydashboard" ,r-shinydashboard)
+ ("r-versions" ,r-versions)))
+ (home-page "https://cran.r-project.org/web/packages/adapr/")
+ (synopsis "Implementation of an accountable data analysis process")
+ (description
+ "This package tracks reading and writing within R scripts that are
+organized into a directed acyclic graph. It contains an interactive Shiny
+application @code{adaprApp()}. It uses Git and file hashes to track version
+histories of inputs and outputs.")
+ (license license:lgpl2.0)))
+
+(define-public r-adapsamp
+ (package
+ (name "r-adapsamp")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "AdapSamp" version))
+ (sha256
+ (base32
+ "1jayjrsiib2ij4rxxj59g71r3xhzl5yqh0lhi8k6cfy03i7dkvis"))))
+ (properties `((upstream-name . "AdapSamp")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-pracma" ,r-pracma)))
+ (home-page "https://cran.r-project.org/web/packages/AdapSamp/")
+ (synopsis "Adaptive sampling algorithms")
+ (description
+ "For distributions whose probability density functions are log-concave,
+the adaptive rejection sampling algorithm can be used to build envelope
+functions for sampling. For others, the modified adaptive rejection sampling
+algorithm, the concave-convex adaptive rejection sampling algorithm, and the
+adaptive slice sampling algorithm can be used. This R package mainly includes
+these four functions: @code{rARS()}, @code{rMARS()}, @code{rCCARS()}, and
+@code{rASS()}. These functions can realize sampling based on the algorithms
+above.")
+ (license license:gpl2)))
+
+(define-public r-adaptalint
+ (package
+ (name "r-adaptalint")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "adaptalint" version))
+ (sha256
+ (base32
+ "15qdcvnnbgcps8j5k79354wsc9alswijv8lcafg2i3lghaw536yf"))))
+ (properties `((upstream-name . "adaptalint")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-lintr" ,r-lintr)
+ ("r-purrr" ,r-purrr)))
+ (home-page "https://cran.r-project.org/web/packages/adaptalint/")
+ (synopsis "Check R code style")
+ (description
+ "This package provides tools to infer the code style (which style rules
+are followed and which ones are not) from one package and use it to check
+another. This makes it easier to find and correct the most important problems
+first.")
+ (license license:gpl3)))