summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 68c4431a68..20730c5daf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2018 Laura Lazzati <laura.lazzati.15@gmail.com>
+;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -775,6 +776,28 @@ named elements: the @code{status}, the @code{headers}, and the @code{body}.")
work well on small screens.")
(license license:gpl3)))
+(define-public r-feather
+ (package
+ (name "r-feather")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "feather" version))
+ (sha256
+ (base32
+ "1q6dbkfnkpnabq8lb6bm9ma44cfcghx2lm23pyk3vg7943wrn1pi"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-hms" ,r-hms)
+ ("r-rcpp" ,r-rcpp)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://github.com/wesm/feather")
+ (synopsis "R Bindings to the Feather API")
+ (description "Read and write feather files, a lightweight binary columnar
+data store designed for maximum speed.")
+ (license license:asl2.0)))
+
(define-public r-haven
(package
(name "r-haven")